Herbers Excel-Forum - das Archiv

Verknüpfung einer WENN .. UND Formel



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Verknüpfung einer WENN .. UND Formel
von: Thomas


Geschrieben am: 22.05.2002 - 15:12:35

Hallo zusammen !

Ich habe folgendes Problem , ich möchte gerne mehrer Bediungungen miteinander Verknüpfen, weiß aber nicht wie ich WENN + UND Formeln Verknüpfe !

Die Formel soll folgendes beinhalten:


- er soll überprüfen ob P11 ="x"
- wenn p11 ein x hat soll er FELD AA1 (ein Datum) einsetzen
- wenn P11 kein x hat, dann soll er gucken ob P9 ein X hat
- wenn P9 auch kein X dann soll er überprüfen ob P7 ein X hat
- wenn P7 kein x hat dann soll er das Feld frei lassen
- wenn aber p7 oder p9 ein X haben dann soll er einfach das nebenfeld +1 rechnen ( also ein Tag weiter )


ich hoffe ihr versteht was ich will !
Im kompliziert ausdrücken bin ich super ! ;)

Danke schonmal und Gruß
Thomas

nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: UDF


Geschrieben am: 22.05.2002 - 15:23:22

Hallo Thomas,

also, so wie Du es formuliert hast, ist immer noch eines nicht klar.

Was soll erscheinen wenn in P7 oder P9, nicht in beiden Zellen, ein x steht. z.B. Tagesdatum?

=WENN((P11="x")+(P9="X")+(P11="X")=0;"";WENN(P9&P11="XX";AA2+1;HEUTE()))

Gruss
Markus


nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: UDF
Geschrieben am: 22.05.2002 - 15:24:55

Sorry, verguckt.

=WENN((P11="x")+(P9="X")+(P7="X")=0;"";WENN(P7&P9="XX";AA2+1;HEUTE()))

Gruss
Markus


nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: Sebastian Müller


Geschrieben am: 22.05.2002 - 15:29:26

Mein Vorschlag;

=WENN(P11=P6;HEUTE();WENN((UND(P9=P6;P7=P6))=WAHR;AB1+1;WENN(P9=P6;HEUTE();WENN(P7=P6;HEUTE();0))))

Wobei die Formel in Zelle AA1 steht.
Heute() steht für das Datum, dass erscheint, wenn Zellen ein x enthalten
P6 ist eine freie Zelle, die das x generell enthält (als Vergleich)

OK?

Sebastian


nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: Iris

Geschrieben am: 22.05.2002 - 15:33:14

=Wenn(P11="x";AA1;Wenn(P9="x";nebenfeld + 1 (was meinst du mit nebenfeld??);Wenn(P7="x"; nebenfeld + 1)))
Was soll gemacht werden wenn nichts davon zutrifft??
Aber so in etwa müßte es funktionieren

nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: Thomas


Geschrieben am: 22.05.2002 - 15:34:03

Ich sag doch ich kann nicht gut erklären ! ;)

Wenn weder in p7
oder p9
oder p11 ein x steht dann soll die Zelle frei bleiben !


-> also -> wenn p11 ein x dann das datum von zelle aa1
wenn p9 ein x ( dann hat er im nebenfeld, da ja dort auch diese bzw. ähnliche formel reinkommt ) schon ein datum und rechnet nur + 1 ( also ein tag später )


nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: Thomas

Geschrieben am: 22.05.2002 - 15:37:47

Noch was zu erklärung !


es steht immer nur in einem Feld ein X

Schonmal danke für die ganzen Formeln
ICh guck mal obs funzt, sonst meld ich mich morgen nochmal ! ;)


nach oben   nach unten

Re: Verknüpfung einer WENN .. UND Formel
von: Thomas


Geschrieben am: 22.05.2002 - 15:43:45

@IRIS: Hey Super !!!!
Danke !
Genau das war die Formel !

Mit Nebenfeld meinte ich ..
also das Ergebnis der Formel sollte z.b in Feld A100, dann war das Nebenfeld A99 ! ;)

Und wenn nix zutrifft sollte es frei sein !

Aber das hab ich hinbekommen !
Nochmal !
Danke !

Echt super hier das Forum ! *freu*

 nach oben

Excel-Beispiele zum Thema "Verknüpfung einer WENN .. UND Formel"
Anzeigen von Werten und Formeln Zeile einfügen und Formeln und Werte übernehmen
Formeln mit Zelladressen speichern Zeilenumbruch in Formel erzwingen
Aktueller Arbeitsblattname in Formel Variable in Formel einbauen
Ein Zeichen in einer Formel suchen Variable in Excel-Formel einbauen.
Summenformel unter Zahlenreihe eintragen Arbeitszeittabelle und SVERWEIS-Formel