Microsoft Excel

Herbers Excel/VBA-Archiv

Text in Zelle

Betrifft: Text in Zelle von: gerry09
Geschrieben am: 23.09.2014 23:52:05

Hallo,
ich habe in Zelle A1 folgenen Text " AZK [301461] - Max, Mustermann 0400-1300 ".
In Zelle B2 hätte ich gerne nur diesen Text " [301461] - Max, Mustermann ".
Ich Arbeite mit Excel 2010. Gibt es dafür eine Formel ?
Es wäre schön wenn mir jemand Helfen könnte.

LG
Gerald

  

Betrifft: AW: Text in Zelle von: Erich G.
Geschrieben am: 24.09.2014 00:39:51

Hi Gerald,
du hast nicht viel über die Aufgabenstellung verraten...

Hier eine Lösung für dein Beispiel. Schreib mal in B2 die Formel
=TEIL(A1;5;28)

Rückmeldung wäre nett! - Grüße aus Kamp-Lintfort von Erich


  

Betrifft: AW: Text in Zelle von: gerry09
Geschrieben am: 24.09.2014 01:06:59

Hi,
mir ist bei der Beschreibung ein Fehler unterlaufen.
Der Text muss so Aussehen " AZK [301461] - Max, Mustermann ".
Das Problem ist das immer AZK, die Nummer u. der Name komplett ausgeschrieben sein muss. Reduzierung der Zelle müsste also von Rechts stattfinden. Da Uhrzeit ja immer mit 4 Stellen angezeigt wird.

LG
Gerald


  

Betrifft: AW: Text in Zelle von: Hajo_Zi
Geschrieben am: 24.09.2014 07:04:21

Hallo Gerald,


Tabelle1

 AB
1 AZK [301461] - Max, Mustermann [301461]
2 AZK 301461 - Max, Mustermann  

verwendete Formeln
Zelle Formel Bereich N/A
B1:B2=WENNFEHLER(TEIL(A1;SUCHEN("[";A1);SUCHEN("]";A1)-SUCHEN("[";A1)+1);"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.15 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: meine Glaskugel zeigt ... von: neopa C (paneo)
Geschrieben am: 24.09.2014 07:40:52

Hallo Gerry

... dass Du mit "Uhrzeiten" diesen Textteil: 0400-1300 meinst?!?

In diesem Fall einfach:

 AB
1AZK [301461] - Max, Mustermann 0400-1300AZK [301461] - Max, Mustermann
2AZK [345678] - Susanne, Musterfrau 0800-1430 AZK [345678] - Susanne, Musterfrau
3  

Formeln der Tabelle
ZelleFormel
B1=LINKS(A1;LÄNGE(A1)-10)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...





  

Betrifft: AW: meine Glaskugel zeigt ... von: gerry09
Geschrieben am: 25.09.2014 11:09:16

Hallo,
Problem ist gelöst vielen Dank für die Hilfe.

LG
Gerald


  

Betrifft: nachgefragt ... von: neopa C (paneo)
Geschrieben am: 25.09.2014 11:36:07

Hallo Gerald,

... jetzt interessiert zumindest mich schon, was für Dich die Lösung denn nun war. Eine der hier aufgezeigten oder eine ganz andere?

Gruß Werner
.. , - ...