Platzhalter in Matrixformel



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Platzhalter in Matrixformel
von: Christian Minninger
Geschrieben am: 23.05.2002 - 14:02:50

Hallo zusammen!

Ich möchte mir in einer Zelle die Anzahl von Zeilen in einem anderen Arbeitsblatt zählen lassen, bei denen gewisse Zellen bestimmte Kriterien erfüllen. Im folgenden Beispiel werden alle Zeilen gewählt, die in Spalte B "Hans" enthalten und in Spalte I "männlich".
={=SUMME((Tabelle1!$B$2:$B$301="Hans")*(Tabelle1!$I$2:$I$301="männlich"))}

So weit, so gut. Nun möchte ich jedoch alle Hans* anzeigen lassen, also alles, was mit Hans anfängt und dann beliebig weitergeht. Wenn ich in obiger Formel nun "Hans*" statt "Hans" eintrage, sucht Excel anscheinend nach dem tatsächlichen Zeichen "*". Wie kann ich in obiger Formel einen Platzhalter einfügen?

Vielen Dank und schönen Gruß,
Christian

nach oben   nach unten

Platzhalter in Matrixformel mit NICHT(ISTFEHLER
von: WF
Geschrieben am: 23.05.2002 - 15:46:40

Hi Chris,

{=SUMME((NICHT(ISTFEHLER(SUCHEN("Hans";B1:B100))))*(I1:I100="männlich"))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter; - das erzeugt sie.

trapp, trapp, trapp, trapp, trapp, brrrrr
WF


http://www.excelformeln.de/
die ultimative Formelseite


nach oben   nach unten

Re: Platzhalter in Matrixformel mit NICHT(ISTFEHLER
von: Christian Minninger
Geschrieben am: 23.05.2002 - 16:02:03

Vielen Dank, es klappt!!!
Immer wieder Super-Service!

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Platzhalter in Matrixformel"