Zellbezüge in Formeln

Bild

Betrifft: Zellbezüge in Formeln
von: Peter
Geschrieben am: 19.02.2005 16:37:39
Hallo, ich will mein Problem mal versuchen zu beschreiben:
Ich habe eine Tabelle mit 500 Zeilen, die ich auf einem weiteren Blatt mit 30 Formeln auswerte.
Mal möchte ich, dass sich die Auswertung auf die Zeien 1 - 500 bezieht, dann auf die Zeilen 60 - 90 etc...
Zur Auswertung ändere ich die Zellbezüge in den Formeln mit "Suchen und Ersetzen".
Das ist aber mühsam und riskant, weil ja auch eine "andere 60" mal irgendwo stehen kann.
Kann man also zwei Zellen auswählen und deren Inhalt (z.B. A1=60, B1=90) als Zellbezug in einer Formel verwenden. Also statt "SUMME(C60:C90)" könnte man vielleicht schreiben "SUMME(C[A1]:C[B1])"
Wäre doch praktisch, wenn es sowas gäbe, man könnte dann Auswertungen viel schneller ändern.
Kann ich so eine Funktion nur nicht finden, oder gibt es Sie wirklich nicht???
Danke für jeden Hinweis.
Peter

Bild

Betrifft: AW: Zellbezüge in Formeln
von: Josef Ehrensberger
Geschrieben am: 19.02.2005 16:42:19
Hallo Peter!
Dafür gibt's INDIREKT() !

=SUMME(INDIREKT("C"&A1&":C"&B1))


Gruß Sepp
P.S.: Rückmeldung nicht vergessen!
Bild

Betrifft: AW: Zellbezüge in Formeln
von: Peter
Geschrieben am: 19.02.2005 17:48:57
Hallo
Hab es probiert, es geht. Das hätte ich nie selbst herausgefunden. Vielen Dank!
Allerdings ist die Schreibweise - besonders bei vielen und komplexeren Formeln recht umständlich. Aber so hat`s der Bill halt gemacht.
Vielen Dank
Peter
Bild

Betrifft: AW: Zellbezüge in Formeln
von: Björn B.
Geschrieben am: 19.02.2005 16:42:44
Hallo Peter,
probier's mal mit
=SUMME(INDIREKT("C" & A1 & ":C" & B1))
Gruß
Björn
Bild

Betrifft: AW: Zellbezüge in Formeln
von: Peter
Geschrieben am: 19.02.2005 19:00:58
Hallo
Hab es probiert, es geht. Das hätte ich nie selbst herausgefunden. Vielen Dank!
Allerdings ist die Schreibweise - besonders bei vielen und komplexeren Formeln recht umständlich. Aber so hat`s der Bill halt gemacht.
Hab es noch weiter probiert, entspricht genau meinen Vorstellungen.
Vielen Dank
Peter


Bild

Betrifft: Danke für die Rückmeldung - o. T.
von: Björn B.
Geschrieben am: 19.02.2005 20:27:33

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellbezüge in Formeln"