Microsoft Excel

Herbers Excel/VBA-Archiv

Formel da nach Zellen einfügen?



Excel-Version: 8.0 (Office 97)

Betrifft: Formel da nach Zellen einfügen?
von: Frank
Geschrieben am: 05.06.2002 - 11:06:24

Servus Leute,

in einer Spalte soll für alle Zeilen immer die gleiche
Formel stehen. Wie kann ich es einrichten, dass die Formel
automatisch da ist, wenn ich eine neue Zeile einfüge?

Grüße

Frank

P.S. Verwende Excel 97 SR 2
.


  

Re: Formel da nach Zellen einfügen?
von: Frank
Geschrieben am: 05.06.2002 - 12:16:03

Ein ersten Schritt zur Lösung habe ich schon (s.u.). Ein weteres Problem in dem zusammenhang besteht jedoch noch. Wie kann ich in der Formel die "neue" Zelle/Zeile ansprechen?

In meinem konkret Fall prüft die Formel den Eintrag und liefert eine Info über Sverweis mit

=WENN(B2="Pool";"";SVERWEIS(B2;$FQ$2000:$FR$3000;2;FALSCH))

wobei B2 die zelle der neue zeile ist, in der der eintrag steht.

Grüße Frank

>
>-----Original Message-----
>From: "Daniel Schmitz"
>Sent: 6/5/2002 2:13:28 A
>-----Originalnachricht-----
>
>Hi Frank,
>
>im VBA-Editor (Alt + F11) ein Doppelklick auf die Tabelle bei der
>es so funktionieren soll und dann folgenden Code einfügen und Deinen
>Bedürfnissen anpassen. Der Bereich rg kann natürlich auch ein anderer
>sein als Spalte B aber ich bin davon ausgegangen sobald in Spalte B
>etwas eingetragen wird wird in die Zeile in Spalte A Deine Formel
>geschrieben.
>
>Private Sub Worksheet_Change(ByVal Target As Excel.Range)
> Dim rg As Range
>
> Set rg = Range("B:B")
>
> If Not Intersect(Target, rg) Is Nothing Then
> Range("A" & Target.Row).FormulaLocal = "= Hier steht Deine Formel"
> End If
>
>End Sub
>
>Hilft Dir das weiter?
>
>Gruss
>Daniel
>
>
>.

  

Re: Formel da nach Zellen einfügen?
von: Hans W. Hofmann
Geschrieben am: 05.06.2002 - 12:20:31

Hallo Frank,

es ist grundsätzlich ungeschickt eine Anwendung so auszulegen, das nachträglich Zellen/Zeilen/Spalten eingefügt werden müssen.
Das gibt früher pder später Ärger.
Bau das so um, daß die Formeln vorgelegt werden können.

Gruß HW


 

Beiträge aus den Excel-Beispielen zum Thema "Formel da nach Zellen einfügen?"