Variabler Arbeitsblatt-Name in Zellenbezug



Excel-Version: 9
nach unten

Betrifft: Variabler Arbeitsblatt-Name in Zellenbezug
von: GerhardS
Geschrieben am: 17.04.2002 - 16:17:44

Hallo,

ich möchte den Inhalt einer Zelle eines anderen Blattes in einer Formel abfragen. Das Problem ist, daß der Name dieses Blattes nicht fest steht, sondern er wird auf dem aktuellen Blatt in einer Zelle als Variable eingegeben.

Z.B. =WENN(Page1!F42="failed";"­F";"P") geht, aber hier beziehe ich mich fest auf Zelle F42 auf Blatt Page1. Wenn der Name des Blattes aber in einer Zelle eingetragen werden kann, z.B. in A1, wie geht das dann???

Ich kapier es einfach nicht!

Danke,
Gerhard.



nach oben   nach unten

Re: Variabler Arbeitsblatt-Name in Zellenbezug
von: Martin Beck
Geschrieben am: 17.04.2002 - 16:49:14

Hallo Gerhard, ich nehme an, Du sprichst von Formeln in einem Tabellenblatt, die manuell eingegeben werden, nicht per VBA. Statt =WENN(Page1!F42="failed";"­F";"P") =WENN(INDIREKT(A1&"!F42")="failed";"­F";"P") Gruß Martin Beck

nach oben   nach unten

Re: Variabler Arbeitsblatt-Name in Zellenbezug
von: GerhardS
Geschrieben am: 17.04.2002 - 16:52:53

Ich bin inzwischen einen großen Schritt weiter und es geht jetzt, aber ... =WENN(INDIREKT(RefSheet & "!F42")="failed";"F";"P") Die Funktion muß ich über ein paar hundert Zeilen kopieren. Wie mach ich das, das sich die F42 dabei auch noch hochzählt? Grübel und Gruß, Gerhard. PS: Die echte Formel ist etwas komplizierter ;-))

nach oben   nach unten

Re: Variabler Arbeitsblatt-Name in Zellenbezug
von: GerhardS
Geschrieben am: 17.04.2002 - 16:59:06

Danke Martin! Ich fand in einem anderen Thread gerade doch noch die Lösung. Wenn ich jetzt noch rausfinde, wie ich beim Kopieren in andere Zeilen die F42 automatisch hochzählen lassen kann, bin ich glücklich. Gruß, Gerhard.

nach oben   nach unten

Re: Variabler Arbeitsblatt-Name in Zellenbezug
von: Martin Beck
Geschrieben am: 17.04.2002 - 17:19:14

Hallo Gerhard, vielleicht geht's auch einfacher, aber: Mal angenommen, die Formel steht in einer Zelle der Zeile 20, z.B. in A20. Schreibe statt =WENN(INDIREKT(A1&"!F42")="failed";"­F";"P") =WENN(INDIREKT(A1&"!F"&Zeile()+22)="failed";"­F";"P") Zeile() liefert die Nummer der Zeile, in der die Formel steht, in meinem Beispiel also 20. Um auf 42 zu kommen also Zeile()+22. Gruß Martin Beck

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Ewige variable"