Microsoft Excel

Herbers Excel/VBA-Archiv

vergleichen und in eine Zelle schreiben

Betrifft: vergleichen und in eine Zelle schreiben von: Aschoff
Geschrieben am: 05.09.2014 11:10:24

Spalte A - enthält Artikelnummern
Spalte B - Texte zur Artikelnummer aus Spalte A

Wie kann ich alle Texte zur selben Artikelnummer in eine Zelle schreiben?

Beispiel:
A B
850.830.16 "Einbaustrahler passend zu allen Clip-Ringen
850.830.16 Außen-Ø: 82 mm
850.830.16 "mit dem als Zubehör erhältlichen GU 10-Sockel (Art.-Nr. 549.95) sind auch HV-Halogenlampen einsetzbar
850.830.16 Achtung - Clipring nicht vergessen!

  

Betrifft: AW: vergleichen und in eine Zelle schreiben von: {Boris}
Geschrieben am: 05.09.2014 11:55:07

Hi,

sortiere Spalte A. Wenn die Spalten Überschriften haben, dann in C2:

=B2

In C3:

=WENN(A4<>A3;C2&ZEICHEN(10)&B3;B3)

Runterkopieren und Spalte C mit Zeilenumbruch formatieren.

In D2:

=ZÄHLENWENN(A$2:A2;A2)=ZÄHLENWENN(A:A;A2)

auch runterkopieren.

Die Formeln in Spalte C und D durch Werte ersetzen.

Spalte D nach FALSCH filtern und die Filterzeilen LÖSCHEN.

Filter wieder entfernen und fertig. ;-)

VG, Boris


  

Betrifft: AW: vergleichen und in eine Zelle schreiben von: Aschoff
Geschrieben am: 05.09.2014 12:13:59

Hallo Boris,
das Problem ist das es immer eine unterschiedliche Anzahl an Texten pro Artikel gibt.
Siehe hier
https://www.herber.de/bbs/user/92493.xlsx


  

Betrifft: AW: vergleichen und in eine Zelle schreiben von: {Boris}
Geschrieben am: 05.09.2014 12:26:18

Hi,

das Problem ist das es immer eine unterschiedliche Anzahl an Texten pro Artikel gibt.

Nein - das Problem ist, dass Du meine Antwort nicht umgesetzt hast. Ich habe es jetzt nochmal in Deiner Datei 1 zu 1 übertragen - und siehe da: Es funktioniert einwandfrei.

VG, Boris


 

Beiträge aus den Excel-Beispielen zum Thema "vergleichen und in eine Zelle schreiben"