Formel per Quellcode einfügen



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: Formel per Quellcode einfügen
von: Jürgen
Geschrieben am: 26.06.2002 - 16:23:04

Hallo Zusammen,
mein Problem ist folgendes:
Ich habe nach einer erfolgten Datenbankabfrage verschiedene Spalten zu summieren. Wenn ich nun per Quellcode beispielsweise die Formel

Cells(zeile,spalte).formula = "=SUMME(A1:A500)"

einfüge, meldet mir Excel in der betreffenden Zelle

#NAME?

Wenn ich nun nur einmal in die Textleiste klicke und mit Enter bestätige, wird die Formel ausgeführt ???

Kann mir jemand sagen, warum die Formel nicht nach dem Einfügen ausgeführt wird, oder mache ich was falsch (Formatierung ???)

Gruß Jürgen

nach oben   nach unten

Re: Formel per Quellcode einfügen
von: Hajo_Zi
Geschrieben am: 26.06.2002 - 16:31:29

Hallo Jürgen


Sub te()
    Dim Zeile As Integer
    Dim Spalte As Integer
    Zeile = 3
    Spalte = 5
    Cells(Zeile, Spalte).FormulaLocal = "=SUMME(A1:A500)"
End Sub

Gruß Hajo

nach oben   nach unten

Re: Formel per Quellcode einfügen
von: Alan Hathway
Geschrieben am: 26.06.2002 - 16:32:14

Tja eine häufig vorkommende und verständliche Frage!

Du musst in VBA die Funktionen AUF ENGLISCH eingeben
SUMME auf englisch heisst SUM

(Es gibt andere Wege aber...)
Wenn Du wissen willst wie eine Funktion auf englisch heisst, nutz mal den Macro Recorder.

Alan Hathway


nach oben   nach unten

Re: Formel per Quellcode einfügen
von: Jürgen
Geschrieben am: 26.06.2002 - 17:14:05

Danke für den Hinweis --> Hat funktioniert !

Zur Übersetzung Deutsch/Englisch verwende ich i.d.R. die mit Office mitgelieferte Datei "VBAListe.xls", die liefert alle Übersetzungen.

Aus den Lösungsansätzen hat sich aber nochmal ein Problem ergeben. Die Formel
"=TEILERGEBNIS(9;A1:A500)" bzw. "=SUBTOTAL(9;A1:A500)" liefert mir ebenfalls die Meldung #NAME? und läßt sich überhaupt nicht zur Zusammenarbeit überreden ??

Hast Du noch ne gute Idee (Vieleicht die anderen Wege ...?)

Gruß Jürgen

nach oben   nach unten

Re: Formel per Quellcode einfügen
von: MRR
Geschrieben am: 26.06.2002 - 17:20:43

Wenn Di Deine Anweisung benutzt, musst Du auf die englische Notation achten:
Cells(Zeile, Spalte).Formula = "=SUM(A1:A500)"
Alles klar?
Matthias

nach oben   nach unten

Re: Formel per Quellcode einfügen
von: Jürgen
Geschrieben am: 27.06.2002 - 09:42:20

Danke und Sorry nochmal, für die direkte Mailansprache

Hier nochmal:
Deine Lösung funktioniert gut mit SUMME, aber leider nicht mit TEILFUNKTION (SUBTOTAL).
Hier bleibt Excel stur und meldet permanent: #NAME?

Hast Du hier vieleicht auch ne Lösung ?

Gruß Jürgen

nach oben   nach unten

Re: Formel per Quellcode einfügen
von: Hajo_Zi
Geschrieben am: 27.06.2002 - 10:06:56

Hallo Jürgen

vielleicht so
ActiveCell.Formula = "=SUBTOTAL(9,D6:D14)"


Gruß Hajo

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Formel per Quellcode einfügen"