Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
516to520
516to520
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Formel per Makro einfügen

Formel per Makro einfügen
11.11.2004 19:54:43
MichiM
Nabend Leute,
ich muss nach einem Copy-Vorgang Formeln neu einfügen.
ThisWorkbook.Worksheets("Rechnungen").Cells(13, LetzteName).FormulaLocal = "=WENN(A2="";"";WENN(G2="";WENN(L2="";WENN(K2="";WENN(J2="";WENN(I2="";WENN(F2<HEUTE();"fällig";"offen");"Kontoauszug");"2. Mahnung");"3. Mahnung");"!Mahnverfahren!");"bezahlt"))"
Nun wird mir aber im Code das Formelergebniss (Text in "") angemeckert.
Was kann man da machen?
Gruss
MichiM

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Formel per Makro einfügen
11.11.2004 20:09:47
Josef Ehrensberger
Hallo Michi!
Die "Gänsefüschen" machen Probleme!
So sollte es klappen.
ActiveCell.FormulaLocal = "=WENN(A2="""";"""";WENN(G2="""";WENN(L2="""";WENN(K2="""";WENN(J2="""";WENN(I2="""";WENN(F2<HEUTE();""fällig"";""offen"");""Kontoauszug"");""2. Mahnung"");""3. Mahnung"");""!Mahnverfahren!"");""bezahlt""))"

Gruß Sepp
AW: Formel per Makro einfügen
11.11.2004 20:11:12
andre
Hallöchen,
einfach mal eingetragen und aufgezeichnet und Du siehst das Problem.
außer dem ersten und letzten Anführungszeichen alle doppelt eingeben
Anzeige

300 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige