Spalte einblenden bei Formelbezug

Bild

Betrifft: Spalte einblenden bei Formelbezug
von: Markus
Geschrieben am: 02.10.2003 18:29:59

Hallo Excel - Experten!

ich arbeite in zwei verschiedenen Tabellbereichen. In Tab1 befinden sich Eingabezellen, die dafür da sind, dass sich in Tab2 ausgeblendete Spalte/n bei Eingabe "x" einblenden. Das ganze funktioniert mit VBA:


Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address = "$A$1" Then
Sheets("Tabelle2!").Columns("C:C").Hidden = Not (UCase(Target.Value) = "X")
End If
End Sub


soweit so gut, wenn man das "x" manuell eingibt und die Eingabetaste betätigt. Jedoch habe ich auch Eingabezellen, wo ein Formelbezug drin steht, der letztlich automatisch für das Wiedereinblenden von Spalten sorgen soll, wenn man z.B. in anderen Eingabezellen manuell das "x" vorgibt.

Formel:

für Zelle "A5": =WENN(ANZAHL2(A1:A3)>0;"x";" ")

.. das wiederrum funktioniert nicht, wenn das "x" per Formel bezogen wird.

ich habe mittlerweile weile herausgefunden, dass das Einblenden bei Eingabe und das Ausblenden bei Entnahme des "x" nur funktioniert, wenn man die Eingabetaste betätigt. Sprich mehrere Zellen weisen ein "x" auf = Spalten eingeblenden, danach mehrere Zellen markieren = Entf. und die Spalten bleiben eingeblendet, obwohl kein "x" besteht.

Wer kann helfen??

Ich danke Euch schonmal vorab vielmals!

Gruß Markus
Bild


Betrifft: AW: Spalte einblenden bei Formelbezug
von: GerdW
Geschrieben am: 02.10.2003 20:47:14

Nutz statt Change das Calculate- Ereignis

Gerd


Bild


Betrifft: AW: Spalte einblenden bei Formelbezug
von: Markus
Geschrieben am: 02.10.2003 21:05:06

Hallo Gerd,

gesagt getan. Da ich dies sowohl als auch wollte, d.h. zwar die Formel in dem Feld stehen habe, aber auch die Formel mit einem "x" überschreiben (zur manuellen Eingabe) möchte, habe ich Deinen Tip parallel laufen. D.h. einmal unter Change und einmal unter Calculate. Sobald ích die Formel eingebe sagt Excel mir:

Laufzeitfehler '424':
Objekt erforderlich


.. und markiert mir die erste "If Target.Adress" gelb

wie darf ich das denn verstehen?

Gruß Markus


Bild


Betrifft: AW: If Target.ADDress mit 2 "d"
von: Matthias G
Geschrieben am: 02.10.2003 21:38:30

check das mal

Gruß,
Matthias


Bild


Betrifft: AW: If Target.ADDress mit 2 "d"
von: Markus
Geschrieben am: 02.10.2003 21:57:15

Hallo Matthias,

gecheckt, hatte mich im forum um ein "d" verschrieben. Habe es im VBA mit doppel- "D" versucht und bringt weiterhin die Fehlermeldung.

Gruß Markus

P.s. Datei unter https://www.herber.de/bbs/user/1264.xls , Tabelle "Eingabe" Zelle "J7" (die Formel steht als Text unter "J4")


Bild


Betrifft: AW: Thread wechseln?
von: Matthias G
Geschrieben am: 02.10.2003 22:21:30

Hallo Markus,
ich schlage vor, wir machen oben in deinem neuesten Thread weiter. Da wird auch das Problem "mehrere Zellen gleichzeitig löschen" behandelt. Du brauchst das Change-Ereignis NICHT!

Gruß,
Matthias


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Spalte einblenden bei Formelbezug"