Formel für: SUCHEN versch. Teilstrings in Spalte

Bild

Betrifft: Formel für: SUCHEN versch. Teilstrings in Spalte
von: Chrstian
Geschrieben am: 18.04.2015 10:54:01

Hallo Leute,
ich suche eine Formel-Lösung für folgendes Problem:
In Spalte A stehen verschiedene Strings und wenn einer von verschiedenen Teilstrings enthalten ist, soll die Formel eine entsprechende Zahl zurückgeben (siehe Beispielmappe).
Bsp Teilstrings - Zahl:
"/Thpd T": 1
"/Thpd W": 1
"/Thpd X": 2
"/Dsk": 3
"/Tw": 4
"/Lttd": 5
"/Ntbk/oth": 5
"/Prc": 5
Die Liste wird ggf. noch erweitert.
Das geht zum Bsp mit 8 verschachtelten WENNs, aber das ist schnell unübersichtlich (siehe Beispielmappe).
Frage: Gibt es eine Formel wie:
=WENN(ISTZAHL(SUCHEN({"/Thpd T"."/Thpd W"."/Thpd X"."/Dsk"."/Tw"."/Lttd"."/Ntbk/oth"."/Prc"};A2)); {1.1.2.3.4.5.5.5};"")
Diese funktioniert so nicht.
https://www.herber.de/bbs/user/97148.xlsx
Könnt ihr mir helfen?
vielen Dank vorab
Christian

Bild

Betrifft: VERGLEICH andersrum
von: WF
Geschrieben am: 18.04.2015 11:32:53
Hi,
in B2 folgende Arrayformel:
{=MAX(ISTZAHL(VERGLEICH({"*/Thpd T*"."*/Thpd W*"."*/Thpd X*"."*/Dsk*"."*/Tw*"."*/Lttd*"."*/Ntbk/oth*"."*/Prc*"}; A2;0))*SPALTE(A:H)) }
runterkopieren
Salut WF

Bild

Betrifft: Du willst ja nicht 1 bis 8 sondern individuell
von: WF
Geschrieben am: 18.04.2015 11:47:18
=MAX(ISTZAHL(VERGLEICH({"*/Thpd T*"."*/Thpd W*"."*/Thpd X*"."*/Dsk*"."*/Tw*"."*/Lttd*"."*/Ntbk/oth*"."*/Prc*"}; A2;0))*{1.1.2.3.4.5.5.5})
Das ist sogar eine "normale" Formel (ohne Array-Abschluss).
WF

Bild

Betrifft: mit Ausgliedern geringfügig kürzer
von: lupo1
Geschrieben am: 18.04.2015 12:24:28
=MAX(ISTZAHL(VERGLEICH("*/"&{"Thpd T"."Thpd W"."Thpd X"."Dsk"."Tw"."Lttd"."Ntbk/oth"."Prc"}&"*";A1;))*{1.1.2.3.4.5.5.5})

Bild

Betrifft: Wow - ausgliedern kann man auch noch
von: Christian
Geschrieben am: 18.04.2015 13:08:00
Hi Lupo,
das funktioniert perfekt. Ich wäre nie darauf gekommen, dass man ein Array so zusammensetzen kann.
Vielen Dank und Grüße
Christian

Bild

Betrifft: genial - vielen Dank
von: Christian
Geschrieben am: 18.04.2015 12:52:24
Hi WF,
"VERGLEICH andersrum" kannte ich noch nicht, sehr schöne Lösung. Insbesondere die "normale" Formel, da die Original-Tabelle ca. 6000 Einträge hat.
Ich hab damit nochmal rumgespielt, um die "0-Ergebnisse" zu elimieren und bin dabei auf:
=WENNFEHLER(INDEX({1.1.2.3.4.5.5.5};VERGLEICH(0; SUCHEN({"/Thpd T"."/Thpd W"."/Thpd X"."/Dsk"."/Tw"."/Lttd"."/Ntbk/oth"."/Prc"};A2);-1));"")
gekommen. Das ist dann wieder der klassische Vergleich, aber mit der Funktion "SUCHEN". Dafür spart man sich die Sternchen bei den Teilstrings.
ich spiel noch ein bisschen weiter. Vielen Dank und Grüße
Christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel für: SUCHEN versch. Teilstrings in Spalte "