Microsoft Excel

Herbers Excel/VBA-Archiv

Formel erweitern nach Hinzufügen von 2 Spalten


Betrifft: Formel erweitern nach Hinzufügen von 2 Spalten von: mike49
Geschrieben am: 28.01.2019 18:32:42

Hallo Leute,
ich musste mein Tabellenblatt um 2 weitere Spalten (E und F) wegen zweiter Arbeitszeit erweitern. Jetzt stimmt natürlich die berechnete Arbeitszeit in Spalte G nicht mehr!
Wer kann helfen?
Vorlage

 ABCDEFGHIJ
11Arbeitseinsatz
(Datum)
Beginn
Arbeitszeit
(Uhrzeit)
Ende
Arbeitszeit
(Uhrzeit)
enthaltene
Pause
(Dauer)
Beginn
Arbeitszeit
(Uhrzeit)
Ende
Arbeitszeit
(Uhrzeit)
Arbeitszeit
gesamt (ohne
Pause)
*aufgezeichnet
am:
(gemäß MiLoG)
Unterschrift
Dienstplaner
Bestätigung der
Anwesenheit
12Di   01.01.           
13Mi   02.01.           
14Do   03.01.           

Formeln der Tabelle
ZelleFormel
A12=DATUM(gewJahr;MONAT($B$4); TAG(B4))
D12=WENN(($C12-$B12)*24>9;0,75/24;WENN(($C12-$B12)*24>6;0,5/24;""))
G12=WENN($C12="";WENN(ODER($H12="U";$H12="K";$H12="U/2"); 4,06-2,03*($H12="U/2"); ""); WENN($D12=""; ($C12-$B12)*24;(($C12-$B12)-$D12) *24))
H12=WENN(B12<>"";"A";"")
A13=WENN(A12="";"";WENN(MONAT(A12+1)=MONAT($B$4); DATUM(gewJahr;MONAT($B$4); TAG(A12+1)); ""))
D13=WENN(($C13-$B13)*24>9;0,75/24;WENN(($C13-$B13)*24>6;0,5/24;""))
G13=WENN($C13="";WENN(ODER($H13="U";$H13="K";$H13="U/2"); 4,06-2,03*($H13="U/2"); ""); WENN($D13=""; ($C13-$B13)*24;(($C13-$B13)-$D13) *24))
H13=WENN(B13<>"";"A";"")
A14=WENN(A13="";"";WENN(MONAT(A13+1)=MONAT($B$4); DATUM(gewJahr;MONAT($B$4); TAG(A13+1)); ""))
D14=WENN(($C14-$B14)*24>9;0,75/24;WENN(($C14-$B14)*24>6;0,5/24;""))
G14=WENN($C14="";WENN(ODER($H14="U";$H14="K";$H14="U/2"); 4,06-2,03*($H14="U/2"); ""); WENN($D14=""; ($C14-$B14)*24;(($C14-$B14)-$D14) *24))
H14=WENN(B14<>"";"A";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
mike49

  

Betrifft: Tabelle ist nicht nachzubauen.... von: MCO
Geschrieben am: 29.01.2019 06:43:54

Hallo Mike49,

Sorry, aber die Daten sind nicht vollständig, so wenig wie die Funktion "gewJahr" aus A12 ff.
Außerdem verweisen die Formeln in obere Zellbereiche, aus denen auch keine Angaben bestehen.

Bitte Beispieldatei hochladen! (anonymisierter Auszug)

Gruß, MCO


  

Betrifft: AW: Tabelle ist nicht nachzubauen.... von: Piet
Geschrieben am: 31.01.2019 14:13:12

Hallo Mike

ich weiss nicht wieviel Arbeit ihr euch machen wollt, das geht m.E. wesentlich einfacher!
Excel verschiebt doch selbst alle Formeln, wenn sie auf Relativ stehen!! - Ohne "$" Zeichen

Mit dem normalen Suchlauf kannst du in allen Formeln das "$H" in "H" umwandeln, erst danach verschiebst du die Spalten. Und wenn du das "$" Zeichen wieder drin haben willst aenderst du nach dem Verschieben die Spalte in allen Formeln von "J" wieder auf "$J" um.

Schon mal probiert den Text in Formeln durch normales Suchen und Ersetzen zu veraendern??

mfg Piet


  

Betrifft: AW: VBA Code von: Winter
Geschrieben am: 01.02.2019 15:03:31

Hallo,
Vielen Dank!

Mfg
Harry


  

Betrifft: Tabelle ist nicht nachzubauen.... von: MCO
Geschrieben am: 29.01.2019 06:44:00

Hallo Mike49,

Sorry, aber die Daten sind nicht vollständig, so wenig wie die Funktion "gewJahr" aus A12 ff.
Außerdem verweisen die Formeln in obere Zellbereiche, aus denen auch keine Angaben bestehen.

Bitte Beispieldatei hochladen! (anonymisierter Auszug)

Gruß, MCO


Beiträge aus dem Excel-Forum zum Thema "Formel erweitern nach Hinzufügen von 2 Spalten"