Matrixformel mit variabler Summenspalte

Bild

Betrifft: Matrixformel mit variabler Summenspalte
von: Steffen B.
Geschrieben am: 24.09.2003 09:31:09

Hallo,

ich möchte folgenden Sachverhalt lösen. Ich habe eine Summierung mit 2 Bedingungen. Aufgrund dieses Forums habe ich eine Matrixformel verwendet. Das klappt bei statischen Tabellen wunderbar.

Nun möchte ich eine Auswahl einbauen, bei der die jeweiligen Monatswerte wählen kann. Dass bedeutet, das der dritte Teil der Matrixformel

{=SUMME((piv_rep_mon!$B$10:$B$120=B7)*(piv_rep_mon!$C$10:$C$120=D7)*(piv_rep_mon!F$10:F$120))}

, genauer der Spaltenbezug (hier "f")variabel gestaltet werden müsste.

Die Spalte habe ich schon ermittelt, sie liegt in einer Zelle vor.

Ich würde mich freuen, wenn jemand eine Lösung hätte.

Steffen

Bild


Betrifft: AW: Matrixformel mit variabler Summenspalte
von: Gert Seler
Geschrieben am: 24.09.2003 10:23:16

Hallo Steffen,
etwas klarer ausdrücken. Was steht in den Spalten A;B;D ???
Wo wird das Datum eingetragen ?
Mit einer WENN-Formel wäre Dir doch auch gedient ?
mfg
Gert


Bild


Betrifft: AW: Matrixformel mit variabler Summenspalte
von: Benne
Geschrieben am: 24.09.2003 10:25:22

Hallo Steffen!

Ich verwende in solchen Fällen die INDIREKT-Funktion.
Da die Spalten- und Zeilenangaben bei mir nummerische vorliegen, benutze ich für die indirekte Addressierung die Z1S1-Variante.

Beispiel:
- A1 = 1 (Zeile)
- B1 = 10 (Spalte)
=> indirekt("Daten!z" & a1 & "s" & b1"; falsch)
So greift Excel auf den Wert in der Zelle Z1S10 (bzw. J1) in der Tabelle "Daten" zu.

Für Deinen konkreten Fall müsste der dritte Funktionsteil dann in etwa so aussehen:
... * indirekt("piv_rep_mon!z10s" & a1 & ":z120s" & a1; falsch)
vorausgesetzt die Spaltenangabe steht in Zelle A1 des aktuellen Tabellenblattes.

Ich hoffe, dass hilft Dir weiter.

Gruß,
Benne


Bild


Betrifft: AW: Matrixformel mit variabler Summenspalte
von: Steffen B.
Geschrieben am: 24.09.2003 10:53:37

@ Benne

Vielen Dank für den Tip. Es funktioniert. Konnte die Formel sogar noch ausbauen und den Zeilenangabe variabel gestalten. Somit habe ich bei Änderungen der zugrundeliegenden Pivottabelle immer alle Daten im Griff.

Also: Der Syntax machts

Danke nochmals


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Matrixformel mit variabler Summenspalte"