Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1108to1112
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formel mit variabler Zelle

Formel mit variabler Zelle
Joseffranz
Hallo,
ich möchte in nachstehender Formel A" durch Cells(XZeile-1,1) ersetzen.
Cells(xZeile, 1).FormulaLocal = "=WENN(ODER(A2=""Summe"";A2="""");"""";WENN(c3="""";""Summe"";A2+1))"
Habe verschiedene Möglichkeiten ohne Erfolg versucht. Vielleicht habt Ihr eine Lösung.
Danke
Josef

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
Funktion per relativer Zelladresse erstellen
24.10.2009 14:29:11
NoNet
Hallo Josef,
zum Erstellen solcher relativer Zelladressen bietet Excel die ZS(Zeilen/SpalteN)-Darstellung an (englisch : RC bzw. Row/Column).
Das kann man auch in VBA anwenden.
Ich empfehle weiterhin die Verwendung der englischsprachigen Funktionsnamen (hier müssen die Argumente dann durch Komma anstatt durch Semikolon getrennt werden !).
Hier die passende VBA-Anweisung für Deinen Fall :

Cells(xZeile, 1).FormulaR1C1 = _
"=if(OR(R[-1]C=""Summe"",R[-1]C=""""),"""",if(R3C3="""",""Summe"",R[-1]C+1))"
Die Adresse R[-1]C (Rows -1 / Column) ist die relative Zelladresse und bedeutet :
"1 Zeile höher als die Zelle in die die Formel/Funktion eingetragen wird in der gleichen Spalte".
Wird diese Funktion also bspw. in A12 eingetragen wird aus R[-1]C die Zelladresse A11
R3C3 hingegen ist eine fixe Zelladresse (Row 3 / Column 3) und spezifiziert die Zelladresse C3 (Zeile 3 / Spalte 3).
Mehr zu dieser Schreibweise findest Du hier :
http://spotlight-wissen.de/lisp/pages/messages/amse-1136883848-12627
Gruß, NoNet
Anzeige
AW: Funktion per relativer Zelladresse erstellen
24.10.2009 15:05:56
Joseffranz
Vielen Dank!
funktioniert super!

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige