Formel mit variabler Zelle

Bild

Betrifft: Formel mit variabler Zelle
von: Airwin Rooker
Geschrieben am: 20.07.2015 11:16:38

Hi Comunity,
ich brauche wieder einmal Hilfe.
Ich habe einen Urlaubsplaner, wo in der Spalte A die Namen der Mitarbeiter stehen. Diese Spalte kann im Laufe des Jahres ergänzt werden.
Nun habe ich in der Zeile 40 einen Zähler, wo die leeren Zelle (=entspricht anwesender Mitarbeiter) gezählt werden. Dies soll aber nur für die Anzahl der vorhandenen Mitarbeiter angewandt werden.
Ich habe daher die Formel:
=WENN(ISTNV(SVERWEIS(B$2;Feiertage;1;0));WENN(WOCHENTAG(B2;2)=6;"";WENN(WOCHENTAG(B2;2)=7;""; ANZAHLLEEREZELLEN(B4:B19)));"")
~f~
eingesetzt. Nun soll jedoch bei
~f~=ANZAHLLEEREZELLEN(B4:B19)
statt "B19" - "B" + Anzahl der Mitarbeiter gem. Spalte A (im Beispiel eben 19) eingesetzt werden. Wie muß da die Formel aussehen.
Danke vorweg für eure Hilfe.
https://www.herber.de/bbs/user/98938.xlsx

Bild

Betrifft: AW: Formel mit variabler Zelle
von: Daniel
Geschrieben am: 20.07.2015 11:32:44
Hi
probier statt dem Zellbezug B4:B19 folgendes:
B4:Index(B4:B38;Anzahl2(B4:B38))
Gruß Daniel

Bild

Betrifft: AW: Formel mit variabler Zelle
von: Rudi Maintaire
Geschrieben am: 20.07.2015 11:46:11
Hallo,
=WENN(ISTNV(SVERWEIS(B$2;Feiertage;1;0));WENN(WOCHENTAG(B2;2)>5;"";ANZAHLLEEREZELLEN(B4:INDEX(B:B; ANZAHL2($A4:$A39)+3)));"")
Gruß
Rudi

Bild

Betrifft: AW: Formel mit variabler Zelle
von: Airwin Rooker
Geschrieben am: 20.07.2015 13:39:26
Danke Rudi, hat super geklappt.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel mit variabler Zelle"