formel Zeile kopieren

Bild

Betrifft: formel Zeile kopieren
von: Lucin
Geschrieben am: 12.07.2015 12:00:02

Hallo
Ich habe folgende Formel die sehr gut funktioniert:
=WENN(ISTFEHLER(FINDEN("test";A1)>0);WENN(ISTFEHLER(FINDEN("test2";A1)>0);"";2);1)]
Nun möchte ich wenn das möglich ist ohne VBA anstelle der 1 dass Excel die ganze Zeile wo die beiden gefundene Wörter enthalten sind in das Sheet "Beispiel" kopiert.
Wenn dann in Zeile A2 u.s.w. diese Wörter ebenfalls enthalten sind ,diese Zeile dann ebenfalls in das Sheet "Beispiel" untereinander kopiert.
Ist das möglich?
Vielen Dank im voraus

Bild

Betrifft: mit einer Formel kann man keine Zeile kopieren ...
von: der neopa C
Geschrieben am: 12.07.2015 13:35:32
Hallo Lucin,
... Du könntest in Deiner Tabelle "Beispiel" jedoch eine Formel so weit nach rechts kopieren, wie Du die Daten aus der Quelltabelle (hier beispielsweise Tabelle1) holen willst. Dabei können jedoch ehemalige Leerzellen schnell zu 0 Werten werden, wenn man nicht entsprechende Vorsorge trifft.
Deine Beispielformel ist auch etwas unglücklich, weil im konkreten Fall eine Ergebnis 2 nicht erzielt werden kann. Deshalb ist das Finden von "test2" nicht notwendig und ich hab diesen Teil im INDEX()-Formelteil weggelassen.
Wenn die Quelldaten alles Textwerte sind, könnten z.B. folgende Formel, die Du in die erste Spaltenzelle einer Zeile einsetzt und nach rechts ziehend kopierst ausreichend sein (evtl. Zahlenwert werden visuell richtig dargestellt sind aber inhaltlich im Ergebnis Textwerte):
=WENN(ISTFEHLER(FINDEN("test";Tabelle1!$A2));"";INDEX(Tabelle1!2:2;SPALTE(A1))&"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit einer Formel kann man keine Zeile kopieren ...
von: Lucin
Geschrieben am: 12.07.2015 14:33:28
Hallo Werner
Danke für den Tip, werde versuchen.
Gruss Lucien

 Bild

Beiträge aus den Excel-Beispielen zum Thema "formel Zeile kopieren"