Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
756to760
756to760
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Formel mit Makro kopieren (viele Sonderzeichen)
23.04.2006 18:01:49
Fabian
Hallo zusammen,
habe ein Problem mit Sonderzeichen in strings.
Ich möchte eine Formel mittels Schleife kopieren und zwar diese:
=WENN($B$7&gt"";WENN($A16&lt&gt"";SVERWEIS($A16;INDIREKT("'"&$B$7&"'!$B$6:"&ADRESSE(45;Listbox!$C$2-1994));Listbox!$C$2+2-B$8;0);"");"")
Wie schaffe ich das?
Problem: Gleichheitszeichen und Hochkommata
Danke fürs nachdenken ;-)
Gruß
Fabian

12
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 18:10:46
Ramses
Hallo
Grundsätzlich kannst du den Kopiervorgang mal mit dem Makrorekorder aufzeichnen
Das

=WENN($B$7>""

wird jedoch nicht funktionieren.
Du vergleichst hier Äpfel mit Birnen, will heissen du vergleichst ob eine Zahl grösser als Text ist.
Da wird EXCEL nicht sehr erfreut darüber sein :-)
Gruss Rainer
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 18:34:53
Fabian
Vielen Dank für die Antwort,
die Formel an sich funktioniert.
Der Makrorecorder nützt in meinem Fall leider nicht, weil er die komplette Zelle kopiert und ich die Formel mit Hilfe eines Strings in einer Prozedur kopieren möchte.
Dabei sind die Sonderzeichen mein Hauptproblem.
Range(Cells(9, spalte), Cells((anzahlKriterien + 8), (spalte + anzahlJahre - 1))).Formula = "WENN($B$7&gt"";WENN($A16&lt&gt"";SVERWEIS($A16;INDIREKT(" ' "&$B$7&"'!$B$6:"&ADRESSE(45;Listbox!$C$2-1994));Listbox!$C$2+2-B$8;0);"");"")"
Es kommt mir auf die Maskierung von Sonderzeichen in strings an. Teile der Formel klappen, nur das "=" und das "'" nicht.
schöne Grüße,
Fabian
Anzeige
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 18:46:07
Solaiman
Hallo Fabian,
1. Hochkomma durch Asc(39) darstellen
2. Anführungszeichen, die innerhalb der anderen Anführungszeichen sein müssen durch 2x "" maskieren.
Gruß
Solaiman
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 19:15:19
Ramses
Hallo
das mit den doppelten Anführungszeichen hast du gut gesehen :-)
Hab' ich nicht drauf geachtet.
Gruss Rainer
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 19:29:27
Fabian
Hallo,
das ersetzen funktioniert fast perfekt. Leider wird bei CHR(61)[=] ein führendes Leerzeichen benötigt, sodass die Formel als Text erkannt und nicht berechnet wird.
Kann die Datei leider nicht hochladen...(aber die Formel funktionert...was aber auch nicht das Problem ist)
Gruß,
Fabian
Anzeige
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 19:33:22
Ramses
Hallo
setz noch ein Hochkomma vor das "=" Zeichen.
Dann verwendet EXCEL die Formel nicht zur Berechnung
Gruss Rainer
Missverständlich ausgedrückt
23.04.2006 20:14:59
Fabian
Die Formel soll schon als Formel in die Zellen geschrieben werden. Excel verlangt im VBA Code nun aber immer am Anfang ein Leerzeichen (vor dem =).
Problem nun: Statt als Formel wird es als Text geschrieben.
(Wenn man davor sitzt, versteht man immer, was man schreibt :P)
Gruß,
Fabian
Noch offen...
23.04.2006 20:19:35
Ramses
Hallo
Das ist nicht nachvollziehbar

Sub test()
Range("A1").FormulaLocal = "=Summe(A2:A3)"
End Sub

Funktioniert einwandfrei z.B.
Daher die Frage noch offen,... auch weil es hier bereits 2:30 morgens ist und ich heute morgen wieder arbeiten soll :-)
Gruss Rainer
Anzeige
AW: Noch offen...
24.04.2006 12:28:47
Fabian
Hallo,
hab das jetzt anders geregelt, zwar nicht schön, aber genauso effektiv. (man darf nun nur die farben nicht mehr ändern...
wie auch immer
Danke für eure Hilfe
Gruß
Fabian
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 19:34:04
Solaiman
Hallo Rainer,
man tut was man kann ;-)
@Fabian
entschuldige bitte ich meinte nicht Asc() sondern Chr() - aber du hast es eh erkannt!
Gruß
Solaiman
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 18:45:12
Fabian
Vielen Dank für die Antwort,
die Formel an sich funktioniert.
Der Makrorecorder nützt in meinem Fall leider nicht, weil er die komplette Zelle kopiert und ich die Formel mit Hilfe eines Strings in einer Prozedur kopieren möchte.
Dabei sind die Sonderzeichen mein Hauptproblem.
Range(Cells(9, spalte), Cells((anzahlKriterien + 8), (spalte + anzahlJahre - 1))).Formula = "WENN($B$7&gt"";WENN($A16&lt&gt"";SVERWEIS($A16;INDIREKT(" ' "&$B$7&"'!$B$6:"&ADRESSE(45;Listbox!$C$2-1994));Listbox!$C$2+2-B$8;0);"");"")"
Es kommt mir auf die Maskierung von Sonderzeichen in strings an. Teile der Formel klappen, nur das "=" und das "'" nicht.
schöne Grüße,
Fabian
Anzeige
AW: Formel mit Makro kopieren (viele Sonderzeichen
23.04.2006 18:56:09
Ramses
Hallo
Ich kenne mich in VBA nicht so gut aus, dass ich Begriffe wie "Maskierung von Sonderzeichen" verstehen würde :-)
Auch kann ich das
"..., weil er die komplette Zelle kopiert und ich die Formel mit Hilfe eines Strings in einer Prozedur kopieren möchte. ..."
nicht verstehen.
Grundsätzlich folgendes:
Eine Formel muss immer mit einem "=" Zeichen beginnen, ... tut es bei dir nicht.
"Listbox" ist eine Tabelle ?
Ansonsten sehe ich da echt keine Probleme beim kopieren, WENN die formel funktioniert, was ich immer noch nicht glaube
 
 A
24Muster
254
26Fehler
27 
Formeln der Tabelle
A26 : =WENN(A25>A24;"OK";"Fehler")
 

umgekehrt
 
 A
24Muster
254
26OK
Formeln der Tabelle
A26 : =WENN(A25<A24;"OK";"Fehler")
 

Kannst du die Tabelle mal hochladen ?
Gruss Rainer
Anzeige

325 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Links zu Excel-Dialogen

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige