Microsoft Excel

Herbers Excel/VBA-Archiv

Anzeigen zutreffender Wert aus Spalten und Zeilen | Herbers Excel-Forum


Betrifft: Anzeigen zutreffender Wert aus Spalten und Zeilen von: Andre
Geschrieben am: 26.01.2010 11:55:56

Hallo liebe Leutz,

hab ne kleine Frage zu meinem Bild.



Wass muss ich eingeben, damit er mir in D4 die zutreffende Nr. zu dem oben genannten Namen anzeigt?

gruss
Andre

  

Betrifft: AW: Anzeigen zutreffender Wert aus Spalten und Zeilen von: Rudi Maintaire
Geschrieben am: 26.01.2010 12:14:34

Hallo,
=INDEX(A:A;VERGLEICH(D3;BEREICH.VERSCHIEBEN(B:B;;VERGLEICH(D2;9:9;)-2;;);))

Gruß
Rudi


  

Betrifft: kleine Arrayformel in D4 von: WF
Geschrieben am: 26.01.2010 12:14:58

Hi Andre,

Spalten B bis H:
{=INDEX(A:A;MIN(WENN(ISTZAHL(FINDEN(D3;B10:H99));ZEILE(10:99))))}

ARRAY-Formel {=geschweifte Klammern} nicht eingeben;
Abschluß der Formel mit gleichzeitig Strg / Shift / Enter (statt Enter allein); - das erzeugt sie.

Kommt der Begriff aus D3 mehrfach vor, wird die erste Trefferzeile ausgegeben.

Salut WF


  

Betrifft: AW: Anzeigen zutreffender Wert aus Spalten und Zeilen von: Andre
Geschrieben am: 26.01.2010 12:26:03

Hallo,

die erste Formel scheint nicht zu funktionieren und die Arrayformel gibt sofort einen Wert aus, ohne das ich vorher in D2 und D3 etwas eingetragen habe.

Mach ich was falsch?

gruss


  

Betrifft: AW: Anzeigen zutreffender Wert aus Spalten und Zeilen von: Andre
Geschrieben am: 26.01.2010 12:29:17

doch diese Formel geht super,

=INDEX(A:A;VERGLEICH(D3;BEREICH.VERSCHIEBEN(B:B;;VERGLEICH(D2;9:9;)-2;;);))

doch wenn da kein Eintrag ist, steht da #NV, das kann man doch irgendwie mit WENN(ISTNV oder sowas wegbekommen oder?

gruss


  

Betrifft: AW: Anzeigen zutreffender Wert aus Spalten und Zeilen von: jockel
Geschrieben am: 26.01.2010 13:26:15

hi André, hast du mal folgendes probiert...: du hattest doch in die richtige richtung gedacht...

=WENN(ISTNV(VERGLEICH(D2;9:9;));"";INDEX(A:A;VERGLEICH(D3;BEREICH.VERSCHIEBEN(B:B;;VERGLEICH(D2;9:9) -2;;);)))

cu jörg


Beiträge aus den Excel-Beispielen zum Thema "Anzeigen zutreffender Wert aus Spalten und Zeilen"