Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Zeile in einer Matrix auswerten

Betrifft: Zeile in einer Matrix auswerten von: SaSei
Geschrieben am: 15.04.2015 10:55:55

Hallo,
Ich habe folgende Matrix (s.unten):

Suchkriterium Spalte: Name 1
Suchkriterium Zeile: V
Bedingung1: zwischen dem 01.01.2015 - 03.01.2015
Ergebnis sollte sein: 2 (2 V's bei Name1 zwischen dem 01.01.-03.01.'15)

Kann mir hierbei jemand behilflich sein??

Vielen Dank im Voraus!
























Name 01.01.2015 02.01.2015 03.01.2015 04.01.2015
Name1 O V V
Name2 V V V O
  

Betrifft: AW: Zeile in einer Matrix auswerten von: SF
Geschrieben am: 15.04.2015 11:07:40

Hola,

wenn du die zu suchenden Daten in 2 Zellen schreibst, z.B. H1 und H2, ginge das z.B. so:

=SUMMENPRODUKT((A2:A3="name1")*(B1:E1>=H1)*(B1:E1<=H2)*(B2:E3="v"))
Gruß,
steve1da


  

Betrifft: AW: Zeile in einer Matrix auswerten von: SaSei
Geschrieben am: 15.04.2015 11:23:18

Funktioniert! Vielen Dank, Steve!


  

Betrifft: AW: Zeile in einer Matrix auswerten von: RQ
Geschrieben am: 15.04.2015 11:11:06

Moin,

Array Formel:
=SUMME((E11:E12=E11)*(F11:I11="v"))
auslösen mit "Strg" + "Umschalt" + "Enter"

in E11 habe ich den Name 1 stehen. Mit der Formel oben kannst Du das ganze dann runterkopieren.


 

Beiträge aus den Excel-Beispielen zum Thema "Zeile in einer Matrix auswerten"