Wert aus Zeilen in Spalten übernehmen

Bild

Betrifft: Wert aus Zeilen in Spalten übernehmen
von: ozne
Geschrieben am: 22.02.2005 16:45:39
Hallo,
ich möchte Daten in eine wie folgt aufgebaute Tabelle übernehmen.
Spalte A / A3-A14: Monate Januar bis Dezember
Zeile 1 / C3-AG3: Tage 1 bis 31
zu befüllende Zellen sind C1 bis AG14
Datenquelle soll ein weiteres Excel Arbeitsblatt sein,
das wie folgt aufgebaut ist.

Spalte A: Mo. - Fr.
Spalte B: Datum im Format tt.mm.jjjj
Spalte C: Zahl (zu kopierender Wert für neue Tabelle)
Die Schwierigkeit liegt hier in der Abstimmung des Datums, da in der einen Tabelle nur die Werte Mo.-Fr. enthalten sind, in der zu befüllenden Tabelle jedoch alle Monatstage aufgeführt sind. Wenn es keinen Wert gibt soll die Zelle leer bleiben.
Wer hat eine Idee, wer kann mir weiterhelfen ???

Bild

Betrifft: AW: Wert aus Zeilen in Spalten übernehmen
von: forum
Geschrieben am: 22.02.2005 19:17:06
eine Mustertabelle wäre für diesen Fall ganz nett...
mit genauer Beschreibung in der Tabelle...
stimmt übrigens dein angegebenes Level ?
wbr
Bild

Betrifft: AW: Wert aus Zeilen in Spalten übernehmen
von: ransi
Geschrieben am: 22.02.2005 19:22:23
hallo ozne
so wie du deine datenstruktur beschreibst,
ist das ganz schwer sverweis() verdächtig.
ransi
Bild

Betrifft: AW: Urlaubskalender ?
von: FP
Geschrieben am: 22.02.2005 19:34:15
Hi ozne,
komischer Name ;-)
Lösung 1: Falls Du Stunden übernehmen willst, d.h. Datum darf mehrfach vorhanden sein, aber keine Texte in Spalte C
Tabelle1
 ABCDEFGHI
2  01020304050607
3Jänner   8,008,008,008,008,00
4Februar 8,008,008,008,00  8,00
5März        
6April        
7Mai        
8Juni        
9Juli        
10August        
11September        
12Oktober        
13November        
14Dezember        
Formeln der Tabelle
C3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=C$2)*Tabelle2!$C$2:$C$367)
D3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=D$2)*Tabelle2!$C$2:$C$367)
E3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=E$2)*Tabelle2!$C$2:$C$367)
F3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=F$2)*Tabelle2!$C$2:$C$367)
G3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=G$2)*Tabelle2!$C$2:$C$367)
H3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=H$2)*Tabelle2!$C$2:$C$367)
I3 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A3)*(TAG(Tabelle2!$B$2:$B$367)=I$2)*Tabelle2!$C$2:$C$367)
C4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=C$2)*Tabelle2!$C$2:$C$367)
D4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=D$2)*Tabelle2!$C$2:$C$367)
E4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=E$2)*Tabelle2!$C$2:$C$367)
F4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=F$2)*Tabelle2!$C$2:$C$367)
G4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=G$2)*Tabelle2!$C$2:$C$367)
H4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=H$2)*Tabelle2!$C$2:$C$367)
I4 : =SUMMENPRODUKT((TEXT(Tabelle2!$B$2:$B$367;"MMMM")=$A4)*(TAG(Tabelle2!$B$2:$B$367)=I$2)*Tabelle2!$C$2:$C$367)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Lösung 2: jedes Datum darf nur 1 Mal in Tabelle 2 Spalte B vorkommen, dafür aber Texte wie "U" oder "K" usw.
Tabelle1
 ABCDEFGHI
22005 01020304050607
3Jänner   UUU8,008,00
4Februar 8,008,008,008,00  K
5März        
6April        
7Mai        
8Juni        
9Juli        
10August        
11September        
12Oktober        
13November        
14Dezember        
Formeln der Tabelle
C3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(C$2&"."&$A3&"."&$A$2)+0);SVERWEIS((C$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
D3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(D$2&"."&$A3&"."&$A$2)+0);SVERWEIS((D$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
E3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(E$2&"."&$A3&"."&$A$2)+0);SVERWEIS((E$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
F3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(F$2&"."&$A3&"."&$A$2)+0);SVERWEIS((F$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
G3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(G$2&"."&$A3&"."&$A$2)+0);SVERWEIS((G$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
H3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(H$2&"."&$A3&"."&$A$2)+0);SVERWEIS((H$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
I3 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(I$2&"."&$A3&"."&$A$2)+0);SVERWEIS((I$2&"."&$A3&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
C4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(C$2&"."&$A4&"."&$A$2)+0);SVERWEIS((C$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
D4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(D$2&"."&$A4&"."&$A$2)+0);SVERWEIS((D$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
E4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(E$2&"."&$A4&"."&$A$2)+0);SVERWEIS((E$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
F4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(F$2&"."&$A4&"."&$A$2)+0);SVERWEIS((F$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
G4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(G$2&"."&$A4&"."&$A$2)+0);SVERWEIS((G$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
H4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(H$2&"."&$A4&"."&$A$2)+0);SVERWEIS((H$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
I4 : {=WENN(ZÄHLENWENN(Tabelle2!$B$2:$C$367;(I$2&"."&$A4&"."&$A$2)+0);SVERWEIS((I$2&"."&$A4&"."&$A$2)+0;Tabelle2!$B$2:$C$367;2;0);"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wert aus Zeilen in Spalten übernehmen"