Microsoft Excel

Herbers Excel/VBA-Archiv

Zelle aktivieren, mit Formel

Betrifft: Zelle aktivieren, mit Formel von: walter mb
Geschrieben am: 23.08.2014 11:42:19

Hallo zusammen,
habe folgende Formel:
=VERGLEICH(G1;A1:A25000;0)
es wird mir die Zeilennummer angezeigt.
Jetzt möchte ich gern das der Courser direkt die Zelle
anspringt bzw. selektiert.

mfg
walter mb

  

Betrifft: AW: Zelle aktivieren, mit Formel von: Hajo_Zi
Geschrieben am: 23.08.2014 11:47:05

Hallo Walter,

das geht nur über VBA und bei Formel ist es ein wenig kompliziert da Private Sub Worksheet_Calculate()

GrußformelHomepage


  

Betrifft: Hallo Hajo hast Du von: walter mb
Geschrieben am: 23.08.2014 11:51:26

Hallo Hajo,
hast Du ein Beispiel ?

mfg
walter mb


  

Betrifft: AW: Hallo Hajo hast Du von: Hajo_Zi
Geschrieben am: 23.08.2014 11:54:39

Hallo Walter,

ich habe es mal für Bilder gemacht.
http://hajo-excel.de/vba_bild_formel.htm

Gruß Hajo


  

Betrifft: Hajo, versteh ich nicht von: walter mb
Geschrieben am: 23.08.2014 12:09:49




  

Betrifft: AW: Hajo, versteh ich nicht von: ransi
Geschrieben am: 23.08.2014 12:32:53

Hallo Walter

Nehmen wir an deine Formel steht in B1.
Dann so:

' **********************************************************************
' Modul: Tabelle1 Typ: Element der Mappe(Sheet, Workbook, ...)
' **********************************************************************

Option Explicit

Private Sub Worksheet_Calculate()
    If Not IsError(Range("B1").Value) Then
        If ActiveSheet Is Sheets("Tabelle1") Then
            Range("A" & Range("B1").Value).Select
        End If
    End If
End Sub



Schau es dir mal an.
https://www.herber.de/bbs/user/92248.xlsm

ransi


  

Betrifft: AW: Zelle aktivieren, mit Formel von: Beverly
Geschrieben am: 23.08.2014 12:39:03

Hi Walter,

meinst du vielleicht so etwas:


Tabelle1

 ABCDEFG
1alle  Hallo  Hallo
2niemand      
3oben      
4unten      
5hier      
6dort      
7Hallo      
8links      

verwendete Formeln
Zelle Formel Bereich N/A
D1=HYPERLINK("#Tabelle1!A"&VERGLEICH(G1;A:A;0);G1)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit




GrußformelBeverly's Excel - Inn


  

Betrifft: Danke an ALLE --) von: walter mb
Geschrieben am: 23.08.2014 13:56:20

Hallo zusammen,
danke an ALLE,
werde wahrscheinlich das Makro von ransi,
erst mal testen,

gruß
walter mb


 

Beiträge aus den Excel-Beispielen zum Thema "Zelle aktivieren, mit Formel"