Microsoft Excel

Herbers Excel/VBA-Archiv

Excel Profis brauche Hilfe bezüglich einer Formel | Herbers Excel-Forum


Betrifft: Excel Profis brauche Hilfe bezüglich einer Formel von: alex
Geschrieben am: 16.01.2010 17:14:15

Hallo Excel - Profis brauche Eure Hilfe für im unten stehenden Link beschriebenes Problem.
https://www.herber.de/bbs/user/67262.xlsx

Danke im Voraus

Alex

  

Betrifft: AW: Excel Profis brauche Hilfe bezüglich einer Formel von: fcs
Geschrieben am: 16.01.2010 17:38:20

Hallo Alex,

das geht mit "einfachen" SVERWEIS-Formeln. Ich hab noch Prüfungen eingebaut, Artikel im Stamm fehlt.

Gruß
Franz

Tabelle1

 FGHI
2ZutatEHMengePreis
3Semmelwürfelkg55,4

Formeln der Tabelle
ZelleFormel
G3=WENN(F3="";"";WENN(ISTFEHLER(SVERWEIS(F3;$A$3:$C$18;2;FALSCH)); "Stamm fehlt";SVERWEIS(F3;$A$3:$C$18;2;FALSCH)))
I3=WENN(ISTFEHLER(SVERWEIS(F3;$A$3:$C$18;1;FALSCH)); "";SVERWEIS(F3;$A$3:$C$18;3;FALSCH)*H3)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


  

Betrifft: Danke für die schnelle Hilfe von: alex
Geschrieben am: 16.01.2010 17:46:10

Danke für die prompte Hilfe - werd mich gleich darüber machen, nochmals Danke.
SG
Alex


  

Betrifft: AW: Excel Profis brauche Hilfe bezüglich einer Formel von: Luschi
Geschrieben am: 16.01.2010 17:47:37

Hallo Alex,

für solche Fälle ist die SVerweis()-Funktion genau das Richtige.

Zelle G3: =SVERWEIS(F3;$A$3:$B$18;2;0)
Zelle I3: =SVERWEIS(F3;$A$3:$C$18;3;0)*H3

Gruß von Luschi
aus klein-Paris


Beiträge aus den Excel-Beispielen zum Thema "Excel Profis brauche Hilfe bezüglich einer Formel"