Microsoft Excel

Herbers Excel/VBA-Archiv

Hilfe beim anpassen einer Formel

Betrifft: Hilfe beim anpassen einer Formel von: Josef_T
Geschrieben am: 14.08.2008 13:54:45

Guten Tag zusammen,

möchte unten stehende Formel so abändern, dass alle Werte in M3:M400 summiert werden, solange in
in N3:N400 oder O3:O400 keine Zahl drin steht, die größer 0 ist.

Wenn in N3:N400 oder O3:O400 eine Zahl größer 0 steht, werden diese nach M3:M400 übertragen. Diese
Zahlen sollen aber nicht mit der unten stehenden Formel ( M3:M400) mit summiert werden.

In der Recherche, konnte ich nichts passendes finden. Meine Versuche, sind allesamt fehlgeschlagen.

Kann mir bitte jemand von Euch einen Tipp geben, was in der Formel abgeändert werden muß?

SUMMEWENN(INDIREKT(D2&"!M3:M400");"größer 0";INDIREKT(D2&"!M3:M400"))

Danke schon mal

Gruß
Josef

  

Betrifft: mit SUMMENPRODUKT von: WF
Geschrieben am: 14.08.2008 14:17:50

=SUMMENPRODUKT((N3:N400>=0)*(O3:O400>=0)*M3:M400)

Salut WF


  

Betrifft: AW: mit SUMMENPRODUKT von: Josef_T
Geschrieben am: 14.08.2008 14:52:31

Hallo WF,

Danke erstmal für Deine Hilfe.
Wie wird denn Deine Formel in meine reingeschrieben?

Da ich weder mit Formeln noch in VBA fit bin, möchte ich dich bitten, mir beim zusammensetzen der Formel
behilflich zu sein.

Danke
Josef


  

Betrifft: AW: mit SUMMENPRODUKT von: heikoS
Geschrieben am: 14.08.2008 17:03:11

Hallo Josef,

die von Walter gepostete Formel wird nicht irgendwo in Deine Formel eingefügt, sondern ersetzt diese.

Zur Erläuterung:
Es werden die Zahlen aus m3:m400 addiert, die in der selben Zeile in den Spalten n und o Zahlen größer 0 stehen haben.

Nur interessehalber:
Wenn die Zahlen aus n und o in die Spalte m übernommen werden, reicht dann nicht auch einfach =summe(m3:m400)?


Gruß Heiko


  

Betrifft: AW: mit SUMMENPRODUKT von: Josef_T
Geschrieben am: 14.08.2008 18:35:26

Hallo Heiko,

Danke erstmal für Deine Erklärung.

Versuche mal zu erklären, was die Formel können sollte :

Die Mappe hat 45 Seiten und ist ein Stundenprogramm mit Ulrlaubsplanung. Alle Blätter sind 100% gleich.
In jedem der 45 Blätter stehen:

In A3:A400 stehen die Datümer
In M3:M400 werden die Stunden die bis Heute gearbeitet wurden, gelistet.
In N3:N400 sind die Urlaubstage gelistet, die ich mit der folgenden Formel summieren möchte, aber nur bis Heute. Vergleich evtl. mit der Spalte A3:A400.

SUMMENPRODUKT((A3:A400 kleiner bzw gleich HEUTE())*(INDIREKT(D2&"!N3:N400")))

In O3:O400 sind die Krankentage gelistet

Obige Formel zählt auch die geplanten Urlaubstage, die z.B. für Dezember 2008 geplant sind und genau das soll nicht geschehen, sondern nur was bis Heute eingetragen ist.

Ich hoffe, so versteht man eher, was die Formel können sollte.
Danke noch mal

Gruß
Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Hilfe beim anpassen einer Formel"