Microsoft Excel

Herbers Excel/VBA-Archiv

Formel Anzahl zählen aber pro Zeile nur einmal

Betrifft: Formel Anzahl zählen aber pro Zeile nur einmal von: Roger
Geschrieben am: 20.02.2013 14:26:00

Hallo liebe Excelfreunde,

Ich komme nicht mehr weiter und hoffe auf euch

In den Zellen I14:N5000 stehen manchmal Zahlen, manchmal keine oder manchmal sogar bis zu sechs Zahlen pro Zeile.

Ich möchte jetzt, die Anzahl Zeilen ermitteln und die Zeilen zählen in welchen eine Zahl steht.
Mit der Formel
=TEILERGEBNIS(2;I14:N5000)
erhalte ich die gesamte Anzahl der Zahlen.

Besten Dank für die Hilfe

  

Betrifft: AW: Formel Anzahl zählen aber pro Zeile nur einmal von: Matthias L
Geschrieben am: 20.02.2013 15:08:23

Hallo

hier eine Variante mit einer Hilfsspalte + Summe

Tabelle1

 ABCD
11231
2 2 1
3Text   
4 Text  
5  Text 
6 1 1
7   3 Zeilen

Formeln der Tabelle
ZelleFormel
D1=WENN(ANZAHL(A1:C1)>0;1;"")
D2=WENN(ANZAHL(A2:C2)>0;1;"")
D3=WENN(ANZAHL(A3:C3)>0;1;"")
D4=WENN(ANZAHL(A4:C4)>0;1;"")
D5=WENN(ANZAHL(A5:C5)>0;1;"")
D6=WENN(ANZAHL(A6:C6)>0;1;"")
D7=SUMME(D1:D6)&" Zeilen"


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Matthias


  

Betrifft: AW: Formel Anzahl zählen aber pro Zeile nur einmal von: Roger
Geschrieben am: 20.02.2013 15:59:23

Besten Dank Matthias,

Leider benötige ich eine Formel ohne Hilfsspalte :-)


  

Betrifft: Zeilenzahl mit Zahlen von: WF
Geschrieben am: 20.02.2013 15:45:39

Hi,

=SUMME(1*(MMULT(1*(ISTZAHL(I14:N5000));ZEILE(1:6)^0)>0))

Salut WF


  

Betrifft: AW: Zeilenzahl mit Zahlen von: Roger
Geschrieben am: 20.02.2013 16:10:35

WF, Perfekt
Danke


 

Beiträge aus den Excel-Beispielen zum Thema "Formel Anzahl zählen aber pro Zeile nur einmal"