Zählen mit Bedingung ohne doppelte

nach unten

Betrifft: Zählen mit Bedingung ohne doppelte
von: Markus
Geschrieben am: 10.09.2021 15:56:28

Hallo , ich bin etwas am verzweifeln...
Für die Lösung habe ich es mal vereinfacht.
Ich habe eine Tabelle mit 4 Spalten. Die Werte in Spalte 1 kenne ich nicht weil sie sich aus anderen Daten ergeben, die Suchwerte für Spalte 2-4 sind bekannt. Ich weiß auch nicht wievielte Zeilen zu zählen sind (max 500)
Ort *Wetter * Sonne * Regen
Bremen * gut * ja * ja
Hamburg * schlecht * ja * ja
Bremen * gut * ja * ja
Münschen * gut * ja * nein
Münschen * gut * nein * ja
Bremen * gut * ja * nein
Berlin * gut * ja * ja
Ich möchte jetzt wissen, wievielte Orte gibt es wo das Wetter=gut, Sonne=ja und Regen =ja ist (natürlich keine doppelten Orte)
In diesem Fall ist das Ergebnis 2 (Zeile 1 und Zeile 7
Hat jemand eine Idee?

nach oben  nach unten

Betrifft: AW: Zählen mit Bedingung ohne doppelte
von: Daniel
Geschrieben am: 10.09.2021 16:10:38

Hi
ich würde da mit zwei Hilfsspalten operieren:
ohne die Hilfsspalten wirds kompliziert und rechenintensiv.
1. Hilfsspalte: fasse alle Spalten zu einem Text zusammen: E2: =A2&B2&C3&D3
2. Hilfsspalte: markiere hier Erstes Vorkommen und Duplikate mit dieser Formel: =Zeile(A2)=Vergleich(A2;A:A;0)
bei ersten Werten steht da WAHR, bei Duplikaten FALSCH
3. mach dann die Auswertung mit =ZählenWenns(B:B;"gut";"C:C;"ja";D:D;"ja";E:E;Wahr)
Gruß Daniel

nach oben  nach unten

Betrifft: AW: Zählen mit Bedingung ohne doppelte
von: Günther
Geschrieben am: 10.09.2021 16:12:23

Moin,
das sinnvollste wäre gewiss, wenn du über Daten | Abrufen und transformieren gehst und entsprechend den Vorgeben filterst. Duplikate entfernen als vorletzten Schritt und zum Schluss (beispielsweise) nach Wetter Gruppieren.
 
Gruß
Günther  |  mein Excel-Blog

nach oben  nach unten

Betrifft: für Solisten nimmt man VERGLEICH
von: WF
Geschrieben am: 10.09.2021 20:58:49

Hi,
Städte in Spalte A /gut-schlecht in B / ja-nein in C und D
=SUMMENPRODUKT((VERGLEICH((B1:B500&C1:C500&D1:D500="gutjaja")*1&A1:A500; (B1:B500&C1:C500&D1:D500="gutjaja")*1&A1:A500;0)=ZEILE(X1:X500))*((B1:B500&C1:C500&D1:D500="gutjaja") *1=1)*(A1:A500<>""))
Salut WF

Excel-Beispiele zum Thema "Zählen mit Bedingung ohne doppelte"