Live-Forum - Die aktuellen Beiträge
Datum
Titel
17.06.2024 19:56:24
17.06.2024 19:39:46
Anzeige
Archiv - Navigation
1736to1740
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Excel Hilfe Zählen ohne doppelte Werte nach Zeitraum

Excel Hilfe Zählen ohne doppelte Werte nach Zeitraum
04.02.2020 11:52:30
nico
Hallo Leute,
ich benötige dringend Hilfe bei folgender Aufgabenstellung:
Ermittlung der Anzahl Kunden nach Jahr und Zeitraum
Datentabelle sieht wie folgt aus:
Datum NameVMA KdNr
14.01.2020 YYY 12345
31.01.2020 YYY 12345
24.01.2020 XXX 54321
31.01.2020 ZZZ 54321
22.01.2020 YYY 2356
03.02.2020 ZZZ 54321
03.02.2020 AAA 2354
03.02.2020 YYY 2356
04.02.2020 AAA 66666
Ergebnis sollte so aussehen:
Ergebnis Jahr Monat01 Monat02
YYY 2 2 1
XXX 1 1 0
ZZZ 1 1 1
AAA 2 0 2
Summe 6 4 4 - ein Kunde kommt 2x vor aber zu unterschiedlichen VMA´s zugeordnet
gesamt 5 3 4 - tatsächliches Ergebnis
Die Ermittlung der Kunden nach Jahr habe ich folgendermaßen gelöst:
=SUMMENPRODUKT(($C$2:$C$110<>"")/ZÄHLENWENN($C$2:$C$110;$C$2:$C$110&""))
Die Ermittlung der Kunden nach Jahr und VMA:
=SUMMENPRODUKT((VERGLEICH($B$1:$B$19999&$C$1:$C$19999;$B$1:$B$19999&$C$1:$C$19999;0) =ZEILE($Q$1:$Q$19999))*($B$1:$B$19999="YYY")*($C$1:$C$19999<>""))
Nun benötige ich allerdings die Ermittlung der Kunden nach VMA und Monat
=SUMMENPRODUKT((VERGLEICH($B$1:$B$19865&$C$1:$C$19865;$B$1:$B$19865&$C$1:$C$19865;0) =ZEILE($Q$1:$Q$19865))*($B$1:$B$19865="YYY")*($A$1:$A$19865>="01.01.2020"*1) *($A$1:$A$19865<="31.01.2020"*1))
Funktioniert nicht da er praktisch alle Zeilen vergleicht und mir im Februar dann nur die Kunden ausspuckt die noch nicht im Januar gekauft haben.
Hat jmd ne Idee?

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Jahr & Monat gehört auch in den VERGLEICH()...
04.02.2020 12:25:02
neopa
Hallo nico,
... dann bedarf es auch klassischen Matrixformeln. F2 nach unten und G2 zusätzlich nach rechts kopieren:
Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFGHI
1DatumNameVMAKdNr  JahrMonat 1Monat 2Monat 3
214.01.2020YYY12345 AAA2020
331.01.2020YYY12345 XXX1100
424.01.2020XXX54321 YYY2210
531.01.2020ZZZ54321 ZZZ1110
622.01.2020YYY2356      
703.02.2020ZZZ54321      
803.02.2020AAA2354      
903.02.2020YYY2356      
1004.02.2020AAA66666      
11         

ZelleFormel
F2{=SUMME((VERGLEICH(JAHR($A$2:$A$19)&$B$2:$B$19&$C$2:$C$19;JAHR($A$2:$A$19)&$B$2:$B$19&$C$2:$C$19;0)=ZEILE(A$2:A$19)-1)*(JAHR($A$2:$A$19)=2020)*($B$2:$B$19=$E2))}
G2{=SUMME((VERGLEICH(MONAT($A$2:$A$19)&$B$2:$B$19&$C$2:$C$19;MONAT($A$2:$A$19)&$B$2:$B$19&$C$2:$C$19;0)=ZEILE(B$2:B$19)-1)*(JAHR($A$2:$A$19)=2020)*($B$2:$B$19=$E2)*(MONAT($A$2:$A$19)=SPALTE(A1)))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß Werner
.. , - ...
Anzeige
AW: Jahr & Monat gehört auch in den VERGLEICH()...
04.02.2020 15:02:56
nico
Vielen Dank ;)
AW: bitte owT
04.02.2020 16:23:29
neopa
Gruß Werner
.. , - ...

320 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige