Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
672to676
672to676
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Mittelwert mit variablen Bedingungen

Mittelwert mit variablen Bedingungen
26.09.2005 15:45:16
stephan
Hallo!
Ich habe ein Problem, in beiliegendem Excel habe ich in den Spalten B, C & D Werte von Meilensteinen eingetragen (Werte werden über Gültigkeitsliste Ausgewählt) und jeweils einen Fertigstellungsgrad.
Gibt es eine Möglichkeit, den Mittelwert der Fertigstellungswerte anzuzeigen, wenn der Benutzer die Bedingungen angibt?
zB: User gibt (viell. über Auswahlbox) die gewünschten Werte für
MS1, MS2, MS3 an und es wird der Mittelwert des Fertigstellungsgrades nach diesen Bedingungen errechnet?
Ich hoffe, Ihr könnt mir helfen...
Danke, Stephan
https://www.herber.de/bbs/user/26921.xls

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
ist aber nicht ganz einfach...
ransi
hallo stefan
...nachzuvollziehen.
 
 ABCDEFGH
1ErgebnisMilestone1Milestone2Milestone3Fertigstellung %   
2ErgebnisXtest3abnahme1abschluss310% test32%
3ErgebnisYtest2abnahme2abschluss320% abnahme1 
4 test2abnahme3abschluss330% abschluss2 
5 test2abnahme3abschluss130%   
6 test2abnahme3abschluss291%   
7 test1abnahme1abschluss210%   
8 test2abnahme3abschluss315%   
9 test3abnahme2abschluss332%   
10 test3abnahme2abschluss250%   
11 test3abnahme1abschluss22%   
12 test1abnahme3abschluss334%   
13 test1abnahme1abschluss187%   
14 test3abnahme3abschluss275%   
15 test2abnahme3abschluss296%   
16 test1abnahme3abschluss350%   
17 test1abnahme3abschluss246%   
18 test1abnahme3abschluss347%   
19 test2abnahme1abschluss344%   
20 test3abnahme2abschluss391%   
21 test3abnahme3abschluss16%   
22 test1abnahme3abschluss211%   
23 test2abnahme2abschluss151%   
24 test2abnahme3abschluss268%   
25 test2abnahme2abschluss227%   
26 test3abnahme1abschluss384%   
Formeln der Tabelle
H2 : {=MITTELWERT(WENN(B2:B26=G2;WENN(C2:C26=G3;WENN(D2:D26=G4;E2:E26))))}
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Die formel musst du mit strg+shift +enter abschliessen.
sonst wirds nix...
ransi
Anzeige
AW: ist aber nicht ganz einfach...
26.09.2005 16:10:51
Stephan
Danke - aber bei dieser variante sind keine Kombinationen der MS Werte möglich.
Geht das auch dynamisch - d.h. der Benutzer kann die 3 Werte beliebig auswählen und anschließend wird der Ø Fertigstellungswert errechnet?
LG, Stephan
AW: ist aber nicht ganz einfach...
ransi
hallo
"...aber bei dieser variante sind keine Kombinationen der MS Werte möglich."
versteh ich nicht.
wenn du B2:D2 kopierst,
G2 -inhalte einfügen-Haken bei transponieren
hast du die gleichen gültigkeiten in G2:G4 wie in B2:D2.
Die kannst du hun und her schalten.
das formel rechnet dir dann den durchnitt abhängig von den gewählte MS werten.
ransi
Anzeige
AW: ist aber nicht ganz einfach...
26.09.2005 16:57:40
Stephan
danke ransi, habe verstanden was du meinst.
noch eine frage: ist es in der gleichen formel au möglich, nur z.b. den Mittelwert von Milestone1 anzuzeigen, also ohne die werte für MS2 und MS3 anzugeben? In dieser Form braucht man ja alle 3 Bedingungen...
LG, Stephan
AW: ist aber nicht ganz einfach...
ransi
hallo stefan
das geht nach dem gleichen strickmuster:
 
 ABCDEFGH
1ErgebnisMilestone1Milestone2Milestone3Fertigstellung %   
2ErgebnisXtest1abnahme1abschluss210% test250%
3ErgebnisYtest1abnahme1abschluss220% abnahme136%
4 test1abnahme1abschluss210% abschluss241%
5 test1abnahme3abschluss334% gesamt30%
6 test1abnahme1abschluss187%   
7 test1abnahme3abschluss350%   
8 test1abnahme3abschluss246%   
9 test1abnahme3abschluss347%   
10 test1abnahme3abschluss211%   
11 test2abnahme3abschluss330%   
12 test2abnahme1abschluss230%   
13 test2abnahme3abschluss291%   
14 test2abnahme3abschluss315%   
15 test2abnahme3abschluss296%   
16 test2abnahme1abschluss344%   
17 test2abnahme2abschluss151%   
18 test2abnahme3abschluss268%   
19 test2abnahme2abschluss227%   
20 test3abnahme2abschluss332%   
21 test3abnahme2abschluss250%   
22 test3abnahme1abschluss22%   
23 test3abnahme3abschluss275%   
24 test3abnahme2abschluss391%   
25 test3abnahme3abschluss16%   
26 test3abnahme1abschluss384%   
Formeln der Tabelle
H2 : {=MITTELWERT(WENN($B$2:$B$26=G2;$E$2:$E$26))}
H3 : {=MITTELWERT(WENN($C$2:$C$26=G3;$E$2:$E$26))}
H4 : {=MITTELWERT(WENN($D$2:$D$26=G4;$E$2:$E$26))}
H5 : {=MITTELWERT(WENN(B2:B26=G2;WENN(C2:C26=G3;WENN(D2:D26=G4;E2:E26))))}
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Anzeige

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige