Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
156to160
156to160
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Wertausgabe wenn 2 Bedingungen erfüllt Erweiterung

Wertausgabe wenn 2 Bedingungen erfüllt Erweiterung
06.09.2002 10:41:04
Klaus
Hallo Forum,
in A1 steht 15.12.2012
in A2 steht 15.09.2002
in A3 soll jetzt der Wert 46 stehen.
Dies konnte ich mit der Wenn und Formel von jinx lösen
=WENN(UND((a2<$a$1);(JAHR($A2)=2002));"46";"")
Jetzt kommt jedoch noch ein weiteres Kriterium hinzu
er soll prüfen und ausgeben
wenn Jahr= 2002 "46"
wenn jahr=2003 "46"
wenn jahr=2004 "92"
wenn jahr=2005 "92"
wenn jahr=2006 "138"
wenn jahr=2007 "138"
wenn jahr>=2008 "185"

Ich zwar schon die Formel erweitert, jedoch funktioniert sie nicht mehr so bald ich auch die Formel für
das Jahr 2008 mit einbinde.
=WENN(UND((a2<$a$1);(JAHR($A2)=2002));"46";WENN(UND((a2<$a$1);(JAHR($A2)=2003));"46";WENN(UND(a2<$a$1);(JAHR($A2)=2004));"92";WENN(UND(a2<$a$1);(JAHR($A2)=2005));"92";WENN(UND(a2<$a$1);(JAHR($A2)=2006));"138";WENN(UND((a2<$a$1);(JAHR($A2)=2007));"138")))))) diese Formel geht

=WENN(UND((a2<$a$1);(JAHR($A2)=2002));"46";WENN(UND((a2<$a$1);(JAHR($A2)=2003));"46";WENN(UND(a2<$a$1);(JAHR($A2)=2004));"92";WENN(UND(a2<$a$1);(JAHR($A2)=2005));"92";WENN(UND(a2<$a$1);(JAHR($A2)=2006));"138";WENN(UND((a2<$a$1);(JAHR($A2)=2007));"138";wenn(und((a2<$a$1);(jahr($a2)>=2008));"185")))))) diese Formel geht nicht mehr

Warum geht diese nicht bzw. wer hat eine bessere Lösung.
Gruss
Klaus

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
Re: Wertausgabe wenn 2 Bedingungen erfüllt Erweiterung
06.09.2002 12:21:24
Jürgen Arnold
Hallo Klaus,

hatte ein ähnliches Problem vor ein paar Wochen.

Habe die Erfahrung gemacht, daß Excel bei diesen Wenn(Und - Abfragen Probleme macht, sobald größer/gleich (>=) abgefragt wird. Probiere die Formel mal spaßhalber aus, ohne dieses Größer (>).
Ein weiterer Grund kann, sein, daß du zu viele wenn-Abfragen hintereinander geschaltet hast. Excel läßt max. 7 zu.
In diesem Fall, einfach 2 getrennte Abfragen laufen lassen und diese dann zusammenführen.

Gruß Jürgen

7 * WENN ohne WENN
06.09.2002 12:25:17
WF
Hi Klaus,

eleganter geht's mit der Multiplikation von Wahrheitswerten:
=(A2 < A1)*((JAHR(A2) < 2004)*46+UND(JAHR(A2) > 2003;JAHR(A2) < 2006)*92+(UND(JAHR(A2) > 2005;JAHR(A2) < 2008)*138+(JAHR(A2) > 2007)*185))

trapp, trapp, trapp, trapp, trapp, brrrrr
WF

http://www.excelformeln.de/
die ultimative Formelseite

Anzeige
Hat geklappt - Danke
06.09.2002 13:21:23
Klaus
Danke

334 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige