Microsoft Excel

Herbers Excel/VBA-Archiv

Summen mit mehreren Bedingungen

Betrifft: Summen mit mehreren Bedingungen von: Werner Schütz
Geschrieben am: 14.10.2014 08:55:38

Ich hatte dieser Tage die Aufgabe, eine Rechnungssumme mit den Bedingungen Kalenderjahr und Kalendermonat zu ermitteln und wunderte mich zum wiederholten Mal, warum dies nicht mit der Formel SUMMEWENNS geht. Im Einzelnen lässt sich aus einer Datumszelle zwar problemlos der darin enthaltene Monat extrahieren, dies funktioniert aber nicht in der SUMMEWENNS-Formel, weil dort offensichtlich aus der Datumszelle der fortlaufende Datumswert abgegriffen wird, aus dem sich - jedenfalls für mich - kein Monatswert ermitteln lässt.

Also musste ich nolens volens wieder die Formel SUMMENPRODUKT anwenden, die zwar für diesen Zweck funktioniert, aber eigentlich doch für eine andere Aufgabe gedacht ist (rein mathematisch ja auch das Aneinanderreihen von Argumenten keine Produktrechnung).

Hatte jemand scho einmal Erfolg mit der SUMMEWENNS- oder einer vergleichbaren Formel ?

  

Betrifft: AW: Summen mit mehreren Bedingungen von: Hajo_Zi
Geschrieben am: 14.10.2014 09:06:45

ich konnte aus Deinem Beitrag nicht lesen wo das Problem ist.

Tabelle8

 ABC
2326.10.2014117
2427.10.20142 
2528.10.20143 
2629.10.20154 
2730.10.20145 
2831.10.20146 
2901.11.20147 
3002.11.20148 
3103.11.20149 
3204.11.201410 
3305.11.201411 
3406.11.201412 
3507.11.201413 

verwendete Formeln
Zelle Formel Bereich N/A
C23=SUMMEWENNS(B23:B35;A23:A35;">=01.01.2014";A23:A35;"<=31.10.2014")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.18 einschl. 64 Bit


GrußformelHomepage


  

Betrifft: AW: Summen mit mehreren Bedingungen von: Werner Schütz
Geschrieben am: 14.10.2014 13:37:42

Hallo Hajo,

das Problem taucht nicht auf, wenn - wie in Deinem Beispiel - komplette Datumswerte einzubeziehen sind, sondern Teile davon, wie in meinem Fall der sich aus dem Datum ergebende Monat. Wenn ich also nicht mit einem vollen Datum rechnen kann, sondern nur einem Teil davon, läuft SUMMEWENNS nicht, es sei denn, man extrahiert in einem Zwischenschritt - den ich vermeiden wollte - den entsprechenden Monat und rechnet dann mit diesem Wert.


  

Betrifft: AW: Summen mit mehreren Bedingungen von: Hajo_Zi
Geschrieben am: 14.10.2014 13:40:43

ich habe das Beispiel nach Deinen Angaben erstellt. Du hast Extra keine Tabelle dargestellt oder Datei verlinkt, da Du die Lösung selber an Deine Bedingungen anpassen wolltest.
Ich erstelle die Lösung für das was im Beitrag dargestellt wurde. Wird diese Darstellung geändert, überlasse ich anderen die Lösung, da ich schon eine Lösung erstellt hatte und dafür Zeit investiert habe. Ich arbeite nicht für den Papierkorb.

Gruß Hajo


  

Betrifft: AW: Summen mit mehreren Bedingungen von: Werner Schütz
Geschrieben am: 14.10.2014 14:22:59

Hallo Hajo,

ich verstehe Deine Aufregung nicht. WEenn Du meinen Beitrag aufmerksam gelesen hättest, wäre deutlich geworden, dass ich kein volles Datum verwenden konnte, sondern nur Teile davon (Jahr, Monat). Insofern geht Dein Beitrag leider an der Fragestellung vorbei.

Dennoch: Nichts für ungut.

Werner


  

Betrifft: dazu ein paar Anmerkungen ... von: neopa C (paneo)
Geschrieben am: 14.10.2014 13:35:47

Hallo Namensvetter,

... SUMMENWENNS()-Formeln sind da, wo sie angewendet werden können (ein Beispiel hat Dir Hajo aufgezeigt), reaktionsschneller als dem entsprechende SUMMENPRODUKT() - Formeln, weil erstere spez. programmiert sind. Dafür können SUMMENPRODUKT()-Formeln flexibler mit notwendigen Bedingungen umgehen, vor allem dann, wenn diese erst anderweitig mit Teilformeln ermittelt werden sollen.

Noch etwas allgemeiner und flexibler sind {=SUMME(...)}- Matrixformeln insbesondere z.B. in Verbindung mit notwendigen WENN()-Teilformeln. Aber sie sind deshalb auch noch ein Kleinigkeit langsamer in der Auswertung als SUMMENPRODUKT()-Formeln.

Gruß Werner
.. , - ...




 

Beiträge aus den Excel-Beispielen zum Thema "Summen mit mehreren Bedingungen"