VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Summen unter Berücksichtigung von Ober- und Untergrenzen

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Summen unter Berücksichtigung von Ober- und Untergrenzen

Problem

Wie kann ich Spalte A auf Werte nach vorgegebenen Ober- und Untergrenzen prüfen und bei Übereinstimmung die Zellen rechts daneben summieren?

Lösung

Matrixformel: =SUMME(($A$2:$A$9>=D1)*($A$2:$A$9<=D2)*$B$2:$B$9)




StandardModule: basMain

Sub Addieren()
   Dim rng As Range
   Set rng = Cells(Rows.Count, 1).End(xlUp).Offset(1, 0)
   rng.Formula = "=SUM(A1:A" & rng.Row - 1 & ")"
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion