VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Summen zwischen zwei Zeiträumen ermitteln

Gruppe

Funktion

Bereich

SUMMEWENN

Thema

Summen zwischen zwei Zeiträumen ermitteln

Problem

Wie kann ich den in Spalte B stehenden Umsatz eines bestimmten Zeitraums ermitteln? Der Starttag steht in Zelle C2, der Endtag in Zelle D2 und die Datumsreihe befindet sich in Spalte A.

Lösung

Folgende Formel: =SUMMEWENN(A:A;">="&C2;B:B)-SUMMEWENN(A:A;">"&D2;B:B)




StandardModule: basMain

Sub Addieren()
   Dim rng As Range
   Set rng = Cells(Rows.Count, 1).End(xlUp).Offset(1, 0)
   rng.Formula = "=SUM(A1:A" & rng.Row - 1 & ")"
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Funktion und SUMMEWENN