zählenwenn bei mehreren Bedingungen



Excel-Version: 97
nach unten

Betrifft: zählenwenn bei mehreren Bedingungen
von: sandra
Geschrieben am: 30.04.2002 - 15:32:25

Hallo zusammen,

ich verzweifele gerade!
Ich möchte in Spalte A die Elemente zählen, die in Spalte B ein A stehen haben. Bei Summewenn ist das unproblematisch, aber wie löse ich das hier???
Die Datengrundgesamtheit ist relativ groß (ca. 1000 Zeilen)!

Danke und Gruß
sandra


nach oben   nach unten

Re: zählenwenn bei mehreren Bedingungen
von: Joachim L.
Geschrieben am: 30.04.2002 - 15:39:23

Hallo Sandra,

schau mal bei:
http://www.excelformeln.de/uberuns.html
unter Formeln.

Gruß Joachim

nach oben   nach unten

Re: zählenwenn bei mehreren Bedingungen
von: matthias
Geschrieben am: 30.04.2002 - 15:48:11

Hi Sandra,

man könnte einen Umweg über eine dritte Spalte gehen.
In dieser Spalte steht:

=WENN(A1="A";1;"")

Nun macht er überall da wo ein A steht eine 1.
Jetzt kannst du die Formel "SummeWENN" wie gewohnt einsetzen.
Falls dich die Einsen aufregen kannst du sie mit ;;; ausblenden.
So merkt keiner den Umweg.

MFG Matze

nach oben   nach unten

Re: zählenwenn bei mehreren Bedingungen
von: sandra
Geschrieben am: 30.04.2002 - 16:43:16

Hallo Joachim,

danke für den Tipp! Ich habe die Funktionen auf Deiner angegebenen Seite (mit angegebenem Beispiel ausprobiert, bekomme jedoch nur bei Eingabe des Summenprodukts einen Wert - ansonsten die Meldung #wert. Leider erweist sich auch diese Funktion für meine Zwecke nicht als brauchbar, aber ich weiß noch nicht genau warum.

Trotzdem danke!!!

Gruß
sandra


nach oben   nach unten

Re: zählenwenn bei mehreren Bedingungen
von: Joachim L.
Geschrieben am: 30.04.2002 - 17:34:07

Hallo Sandra,

wenn um die Formeln(Array-Formel) eine Geschweifte Klammer {} ist, dann darfst Du diese nicht mit eingeben. Du gibst die Formel ohne geschweifte Klammer ein und schliest dann mit Strg + Shift + Enter ab.

Gruß Joachim


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "zählenwenn bei mehreren Bedingungen"