Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

felexibler Verweis mit mehreren Bedingungen

felexibler Verweis mit mehreren Bedingungen
Chris
Hy Leute,
folgendes Hinderniss.
Ich hole aus SAP eine Excelliste.
Diese möchte ich gern zu einer Vorlage verknüpfen. Diese Excelliste ändert sich aber monatlich.
Des Wegen dürfen die Bezüge nicht absolut sein.
Ich häng mal eine Datei mit meinem Problem an...
https://www.herber.de/bbs/user/73174.xls
Gruß Chris

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
AW: felexibler Verweis mit mehreren Bedingungen
21.01.2011 11:07:11
Eugen
Hi Chris
die Zuordnung zu den einzelnen Gruppen nochmal checken, aber ich denke,
ich hab Dich richtig verstanden !
https://www.herber.de/bbs/user/73175.xls
Gruss
Eugen
AW: felexibler Verweis mit mehreren Bedingungen
21.01.2011 11:43:47
Chris
Hy Eugen....
Die Ergebnisse im Blatt "Ergebnis" stimmen schon, aber die sind leider nicht verknüpft...
Es ist so, dass ich im Blatt "Eingabe" neuere Werte einfach drüberkopieren möchte und im Blatt "Ergebnis" soll er das automatisch verknüpfen.
Ich hab es mit Summenprodukt probiert, aber da die Kriterien in verschiedenen Zeilen liegt, ist dies nicht möglich.
Anzeige
AW: felexibler Verweis mit mehreren Bedingungen
21.01.2011 12:44:15
fcs
Hallo Chris,
mit einigen Hilfsberechnungen die die relevanten Zeilen und Bereiche ermitteln kann man mit SUMMENPRODUKT und INDIREKT variable Eingabedaten auswerten.
https://www.herber.de/bbs/user/73177.xls
Gruß
Franz
Ergebnis

 ABCDEFGHIJKLMN
1    SchuheT-Sirts Zeile1Zeile2EingabeCDEF
23100000Erlöse999999Fremde Dritte1.126,002.388,00 27 Eingabe!C2:C7Eingabe!D2:D7Eingabe!E2:E7Eingabe!F2:F7
3  G001Intern500,00500,00        
4  G101-G1xxverb. Unt.409,00271,00        
5  Ergebnis 2.035,003.159,00        
6              
73200000Aufwendungen999999Fremde Dritte678,00775,00 914 Eingabe!C9:C14Eingabe!D9:D14Eingabe!E9:E14Eingabe!F9:F14
8  G001Intern144,00144,00        
9  G101-G1xxverb. Unt.890,001.300,00        
10  Ergebnis 1.712,002.219,00        
11              
123300000Ergebnis999999Fremde Dritte448,001.613,00 16      
13  G001Intern356,00356,00        
14  G101-G1xxverb. Unt.-481,00-1.029,00        
15  Ergebnis 323,00940,00        

Formeln der Tabelle
ZelleFormel
E2=SUMMENPRODUKT(((INDIREKT($K2)=$C2)+(INDIREKT($K2)="#"))*INDIREKT(M2))
F2=SUMMENPRODUKT(((INDIREKT($K2)=$C2)+(INDIREKT($K2)="#"))*INDIREKT(N2))
H2=VERGLEICH(A2;Eingabe!$A$1:$A$500;0)
I2=H7-2
K2=$J$1&"!"&K$1&$H2&":"&K$1&$I2
L2=$J$1&"!"&L$1&$H2&":"&L$1&$I2
M2=$J$1&"!"&M$1&$H2&":"&M$1&$I2
N2=$J$1&"!"&N$1&$H2&":"&N$1&$I2
E3=SUMMENPRODUKT((INDIREKT($K2)=$C3)*INDIREKT(M2))
F3=SUMMENPRODUKT((INDIREKT($K2)=$C3)*INDIREKT(N2))
E4=SUMMENPRODUKT((LINKS(INDIREKT($K2); 2)="G1")*INDIREKT(M2))
F4=SUMMENPRODUKT((LINKS(INDIREKT($K2); 2)="G1")*INDIREKT(N2))
E5=SUMME(E2:E4)
F5=SUMME(F2:F4)
E7=SUMMENPRODUKT(((INDIREKT($K7)=$C7)+(INDIREKT($K7)="#"))*INDIREKT(M7))
F7=SUMMENPRODUKT(((INDIREKT($K7)=$C7)+(INDIREKT($K7)="#"))*INDIREKT(N7))
H7=VERGLEICH(A7;Eingabe!$A$1:$A$500;0)
I7=H12-2
K7=$J$1&"!"&K$1&$H7&":"&K$1&$I7
L7=$J$1&"!"&L$1&$H7&":"&L$1&$I7
M7=$J$1&"!"&M$1&$H7&":"&M$1&$I7
N7=$J$1&"!"&N$1&$H7&":"&N$1&$I7
E8=SUMMENPRODUKT((INDIREKT($K7)=$C8)*INDIREKT(M7))
F8=SUMMENPRODUKT((INDIREKT($K7)=$C8)*INDIREKT(N7))
E9=SUMMENPRODUKT((LINKS(INDIREKT($K7); 2)="G1")*INDIREKT(M7))
F9=SUMMENPRODUKT((LINKS(INDIREKT($K7); 2)="G1")*INDIREKT(N7))
E10=SUMME(E7:E9)
F10=SUMME(F7:F9)
E12=+E2-E7
F12=+F2-F7
H12=VERGLEICH(A12;Eingabe!$A$1:$A$500;0)
E13=+E3-E8
F13=+F3-F8
E14=+E4-E9
F14=+F4-F9
E15=SUMME(E12:E14)
F15=SUMME(F12:F14)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Anzeige
AW: felexibler Verweis mit mehreren Bedingungen
21.01.2011 12:31:31
Chris
So, hab es jetzt selber gelöst mit Hilfe zweier Hilfsspalten.
Diese habe ich außerhalb des Eingabebereiches geschrieben und ausgeblendet. somit stören sie mich nicht.
Ich zeig sie euch nachher...

349 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige