Microsoft Excel

Herbers Excel/VBA-Archiv

Summe eines Bereiches wenn 2 Kriterien | Herbers Excel-Forum


Betrifft: Summe eines Bereiches wenn 2 Kriterien von: Andre
Geschrieben am: 08.12.2009 13:22:30

Hallo liebe Leute,

mal wieder eine kleine Frage.

hier ein Beispiel.



was mache ich da genau für einen Fehler?
hab es schon mit Summewenn versucht, doch die kann nur ein Kriterium oder?

Also er soll nur die Werte des Bereiches A3:A7 zusammenrechnen, wenn B3:B7;B10 UND wenn C3:C7;B11

danke für Eure Mühen.

  

Betrifft: AW: Summe eines Bereiches wenn 2 Kriterien von: ptonka
Geschrieben am: 08.12.2009 13:32:35

Hallo Andre,

ich hätte folgende Idee.
Erzeuge eine Hilfsspalte in Spalte D, wo Du die Werte aus Spalte B und C verkettest.
Also z.B. =verketten(B3;C3) für Zeile 3.

Dann kannst Du mit der Formel: =SUMMEWENN(D3:D7;VERKETTEN(B9;B10);A3:A7)
in E3 die Summen bilden.

Die Spalte D kannst Du ja ausblenden - oder Du schreibst die Verkettungen in Spalte IV.
Das bleibt Dir überlassen.

Gruß,

Ptonka


  

Betrifft: AW: Summe eines Bereiches wenn 2 Kriterien von: Rudi Maintaire
Geschrieben am: 08.12.2009 13:33:03

Hallo,
=summenprodukt((b3:B7=B10)*(c3:c7=B11)*a3:a7)
oder du bastelst dir in einer Hilfsspalte das Kriterium zusammen.
D3:=B3 &C3 und runterkopieren
=Summewenn(D3:D7;B10&B11;A3:A7)

Gruß
Rudi


Beiträge aus den Excel-Beispielen zum Thema "Summe eines Bereiches wenn 2 Kriterien"