zählen mit zwei Bedingungen

Bild

Betrifft: zählen mit zwei Bedingungen
von: Wolfango
Geschrieben am: 14.07.2015 13:39:04

Hallo Experten,
ich möchte zählen mit zwei Bedingungen.
ZÄHLENWENNS ist mir bekannt, ich bekomme es aber auf meine Aufgabenstellung nicht angewendet. Vielleicht ist aber auch ein ganz anderer Weg erforderlich!?
Siehe Beispiel:
https://www.herber.de/bbs/user/98813.xlsx
In der Tabelle auf der linken Seite sind sowohl Namen als auch Datumsüberschriften veränderlich (Anm: es sind stets aufeinander folgende Datumswerte).
In der rechten Tabelle soll immer der entsprechende Namen gezählt werden. Hierbei soll die Formel automatisch erkennen, in welcher Datumsspalte gezählt werden muss!
Ich habe das Ergebnis mal manuell für den 06.01.15 eingetragen.
Was fehlt ist ein Automatismus, dass die Formel sich auch am 06.01.15 der linken Tabelle orientiert.
Danke fürs Nachdenken!
Gruß, Wo

Bild

Betrifft: AW: zählen mit zwei Bedingungen
von: SF
Geschrieben am: 14.07.2015 13:44:07
Hola,
in L5 zum nach rechts und nach unten kopieren:

=SUMMENPRODUKT(($B$2:$H$2=L$4)*($B$3:$H$12=$K5))
Gruß,
steve1da

Bild

Betrifft: AW: zählen mit zwei Bedingungen
von: Wolfango
Geschrieben am: 14.07.2015 14:16:27
Großartig! Funktioniert!
Dankeschön!

Bild

Betrifft: z.B. mit SUMMENPRODUKT() ...
von: der neopa C
Geschrieben am: 14.07.2015 13:47:31
Hallo Wolfgang,
... in L5: =WENN(($K5="")+(L$4="");"";SUMMENPRODUKT(($B$3:$I$99=$K5)*($B$2:$I$2=L$4))) und Formel nach rechts und unten ziehend kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit SUMMENPRODUKT() ...
von: Wolfango
Geschrieben am: 14.07.2015 14:18:07
...auch besten Dank!
Verstehe nicht ganz, warum der Teil vor der Summenproduktformel notwendig ist....ohne diesen funktioniert's doch auch!?
Gruß, Wo

Bild

Betrifft: Du hattest geschrieben ...
von: der neopa C
Geschrieben am: 14.07.2015 14:32:06
Hallo Wolfgang,
... dass "...sowohl Namen als auch Datumsüberschriften veränderlich..." . Das heißt für mich, dass z.B. auch mal weniger Namen da sein könnten als Formeln kopiert wurden.
Und Du willst ja nicht Leerzellen zählen (bei fehlenden Namen) oder 0 Ergebnis haben, wenn gar kein Datum auszuwerten ist. Oder?
Und als ich mit Deine Anfrage las, war noch keine Antwort da.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Du hattest geschrieben ...
von: Wolfango
Geschrieben am: 14.07.2015 14:39:43
...Ok...verstanden! Vielen Dank noch mal!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "zählen mit zwei Bedingungen"