Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
896to900
896to900
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Mittelwert und Wenn-Funktion

Mittelwert und Wenn-Funktion
20.08.2007 22:48:51
Katja
Guten Abend liebe Leute,
möchte den Mittelwert berechnen, wenn entweder eine Uhrzeit kleiner oder größer ist.
Beispiel:
Spalte A Spalte B
Beginn Stundenbelegung
10:15 6:05
11:20 2:00
17:00 1:30
Mittelwert der Spalte B berechnen, wenn kleiner bzw. ab 17:00 Uhr.
Habe es mal so versucht, aber irgendwie ist ein Fehler drin:
=MITTELWERT(WENN(a1:a3kleiner=17:00;b1:b3)
Würde mich über Hilfe sehr freuen.
LG
Katja

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Mittelwert und Wenn-Funktion
21.08.2007 08:52:11
HermannZ
Hallo Katja;
deine Werte stehen in A1:B10 dann so;
{=MITTELWERT(WENN(A1:A10<ZEITWERT("17:00");B1:B10))}
PS; die geschweiften Klammern nicht eingeben sondern die Formel mit Shift-Strg-Enter abschliessen.
Gruss Hermann

AW: Mittelwert und Wenn-Funktion
21.08.2007 08:58:30
ingUR
Hallo,, Katja,
eine Lösung ist die Kombination der Zellenformeln Summenprodukt und Zählenwenn, wenn der die Zeilenbelegung von 1 bis 5 ist ,einschließlich der Überschrift und folgender Leerzeile, so wie in Deinem Beispieldatenreihe
=SUMMENPRODUKT((A1:A5
Um mit der Fprmel Mittelwert zu arbeiten, ist der Wertebereich exakt zu beschreiben und die Formel als Array-Formel einzugeben, also die Eingeabe ist mit der Tastenkombination [STRG][SHIFT][ENTER] abzuschliessen:
 
 ABC
1BeginnStundenbelegung 
2   
310:1506:05 
411:2002:00 
517:0501:30 
6   
7208:0504:02
8  04:02
Formeln der Tabelle
A7 : =ZÄHLENWENN(A3:A5;"<="&17/24)
B7 : =SUMMENPRODUKT((A1:A5<=17/24)*1;B1:B5)
C7 : =SUMMENPRODUKT((A1:A5<=17/24)*1;B1:B5)/ZÄHLENWENN(A1:A5;"<="&17/24)
C8 : {=MITTELWERT(WENN(A3:A5<=17/24;B3:B5))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Im Beispiel habe ich die Zeit 17:00 in 17:05 abgeändert. Da ich ihct genau verstanden habe, was Du mit der Formulierung «wenn kleiner bzw. ab» meinst, habe ich das Kriterium nach Deiner Formel benutzt.
Die Vergleichszeit 17:00, habe ich als Dezimalwert 17/24 eingesetzt, das die Formeln SUMMENPRODUKT und MITTELWERT ansonsten zu 17:00 nicht richtig interpretieren. Selbstverstänflich könnte aber auch ein Zellenbezug auf die Zelle, die den gültigen Begrenzungswert enthält, dort eingesetzte werden.
 
 ABC
1BeginnStundenbelegung11:00
2   
310:1506:05 
411:2002:00 
517:0501:30 
6   
7209:3506:05:00
8  06:05:00
Formeln der Tabelle
A7 : =ZÄHLENWENN(A3:A5;"<=17:00")
B7 : =SUMMENPRODUKT((A3:A5<="17:00")*1;B3:B5)
C7 : =SUMMENPRODUKT((A1:A5<=C1)*1;B1:B5)/ZÄHLENWENN(A1:A5;"<="&C1)
C8 : {=MITTELWERT(WENN(A3:A5<=C1;B3:B5))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß,
Uwe
Anzeige

329 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige