Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl ohne Duplikate gekoppelt mit Wenn-Funktion

Betrifft: Anzahl ohne Duplikate gekoppelt mit Wenn-Funktion von: Sonja
Geschrieben am: 30.07.2014 17:33:03

Hallo,

ich möchte in einer (gefühlt ewig langen) Excel-Tabelle folgendes berechnen:

- Anzahl von Kunden (ohne Duplikate)
- die im Jahr X eingekauft haben

Beispieltabelle:

A B
|A|2010|
|A|2010|
|B|2010|
|C|2010|
|A|2011|
|A|2012|
|B|2012|

Frage: Wie viele Kunden haben im Jahr 2010 eingekauft?
Antwort: 3

Eigentlich sollte das gar nicht so schwierig sein, aber ich bekomme es leider nicht hin!

Vielen Dank bereits im Voraus für eure Hilfe!
VG Sonja

  

Betrifft: Lösung auf www.excelformeln.de von: NoNet
Geschrieben am: 30.07.2014 17:43:32

Hallo Sonja,

hier eine Lösung gemäß dieser Seite :
http://www.excelformeln.de/formeln.html?welcher=334

ABCDE
1
2
3
4
5
6
7
8

Funktionen im Tabellenblatt
Zelle Formel 
E2   =SUMMENPRODUKT((VERGLEICH($A$1:$A$99&$B$1:$B$99;$A$1:$A$99&$B$1:$B$99;0)=ZEILE($1:$99)*($A$1:$A$99=D2)*($B$1:$B$99<>""))*1) 
E3   =SUMMENPRODUKT((VERGLEICH($A$1:$A$99&$B$1:$B$99;$A$1:$A$99&$B$1:$B$99;0)=ZEILE($1:$99)*($A$1:$A$99=D3)*($B$1:$B$99<>""))*1) 
E4   =SUMMENPRODUKT((VERGLEICH($A$1:$A$99&$B$1:$B$99;$A$1:$A$99&$B$1:$B$99;0)=ZEILE($1:$99)*($A$1:$A$99=D4)*($B$1:$B$99<>""))*1) 

Tabelle eingefügt mit Syntaxhighlighter 4.15

Gruß, NoNet


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl ohne Duplikate gekoppelt mit Wenn-Funktion"