Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1556to1560
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Zählen ohne Duplikate und mit Bedingung

Zählen ohne Duplikate und mit Bedingung
18.05.2017 14:11:11
Fra
Hallo,
ich stehe vor einem kleinen Problem. Ich habe eine Tabelle mit vier Spalten:
Mitglied, Januar, Februar, März. Die Mitglieder haben in den Monaten verschiedene Werte. Nun möchte ich wissen wieviele Mitglieder je Monat überhaupt einen Wert haben.
Einfachheithalber s.: Userbild
Per Hand wäre das:
Januar 3
Februar 2
März 2
Ich habe leider nichts passendes finden können.
Wer hat einen Tip für mich?

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählen ohne Duplikate und mit Bedingung
18.05.2017 15:14:20
Fra
Hallo,
vielen Dank. Die Formeln kenne ich. Nur passen sie nicht auf meinen Fall bzw. weiß ich nicht wie ich sie anpassen kann.
Ich möchte nicht wissen welches Mitglied wieviele Werte hat, sondern wieviele Mitglieder Werte haben.
AW: Zählen ohne Duplikate und mit Bedingung
18.05.2017 15:21:35
Daniel
Hi
beispielsweise mit dieser Matrixformel (Eingabe immer mit STRG+SHIFT+ENTER abschließen)
=SUMME(WENN(B2:B99="";0;1/ZÄHLENWENNS($A2:$A99;$A2:$A99;B2:B99;"")))
den Zellbereich bitte anpassen.
Gruß Daniel
Anzeige
AW: Zählen ohne Duplikate und mit Bedingung
18.05.2017 15:30:43
Fra
Hallo Daniel,
vielen Dank. Das sieht gut aus und löst vor allem den Knoten in meinem Kopf.
Beste Grüße
Fra
AW: alternativ kürzer mit HÄUFIGKEIT() ...
19.05.2017 00:11:06
...
Hallo Fra,
... in folgender klassischen Matrixformel:

=SUMME(N(HÄUFIGKEIT(WENN(B2:B99"";$A2:$A99);$A2:$A99)>0))
(Eingabe mit STRG+SHIFT+ENTER abschließen)
Gruß Werner
.. , - ...

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige