Liste ohne Duplikate

Bild

Betrifft: Liste ohne Duplikate
von: Peter
Geschrieben am: 11.11.2015 13:21:24

Guten Tag zusammen,
mal wieder brauche ich Rat und Tat :-)
Tablellenblatt 1
SpalteA-----SpalteB--------SpalteC
Kunde-------EAN------------Menge
25100-------4005900145819---12
25100-------4005900114044---3
2345--------4005808283712---4
5565--------4005900145819---1
25100-------4311501304815---2
2345--------40157320--------5
Tabellenblatt 2
möchte ich gerne eine Auswertung
GESAMTMENGE in B
SpalteA---------SpalteB
EAN-------------gesamt Menge
4005900145819----13
4005900114044----3
4005808283712----4
4311501304815----2
40157320---------5
Wenn jetzt eine neue Artikelnummer in der Spalte A Tabelle1 dazukommt bzw. neue Daten, soll diese dann in der Tabelle2 auftauschen und diese Zusammenzählen. Bei der Liste wird täglich neue Datem unten drangehängt.
Mein problem bei der Auswertung sind die Doppelte Werte und das es nur einmal diese EAN erscheint. Er müsste sofort erkennen (Tablle2 ) das eine neue EAN dazugekommen ist.
Wie würde das funktionieren ?
Danke an ALLE
Peter

Bild

Betrifft: AW: am schnellsten und einfachsten mit PIVOT owT
von: ... neopa C
Geschrieben am: 11.11.2015 13:30:41
Gruß Werner
.. , - ...

Bild

Betrifft: Duplikate eliminieren
von: WF
Geschrieben am: 11.11.2015 13:53:29
Hi,
in A2 der Tabelle2 steht: =Tabelle2!B2
in A3 der Tabelle2 die Arrayformel:
{=WENNFEHLER(INDEX(Tabelle1!B$2:B$99;VERGLEICH(1;(ZÄHLENWENN(A$2:A2;Tabelle1!B$2:B$99)=0) *(Tabelle1!B$2:B$99<>"");0));"") }
runterkopieren
in B2 der Tabelle2:
=SUMMEWENN(Tabelle1!B:B;A2;Tabelle1!C:C)
runterkopieren
Salut WF

Bild

Betrifft: AW: Duplikate eliminieren
von: Peter
Geschrieben am: 11.11.2015 14:53:33
würde es ohne Matrix gehen z.b über INEX oder Vergleich?

Bild

Betrifft: AW: geht nicht ohne Matrx, aber ohne {} Eingabe...
von: ... neopa C
Geschrieben am: 11.11.2015 16:03:17
Hallo Peter,
... als Formellösung sowohl mit als auch ohne Hilfsspalte. Erstere würde unter dem Einsatz von AGGREGAT() funktionieren.
Aber ich verweise nochmal darauf, dass eine PIVOTauswertung viel schneller in der Auswertung ist und um die vorzunehmen man nur ca 10 Mausklicks benötigt. Warum willst Du keine PIVOTauswertung vornehmen?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: geht nicht ohne Matrx, aber ohne {} Eingabe...
von: Dieter
Geschrieben am: 11.11.2015 16:52:37
Hallo Werner,
Ich erstelle die Liste für eine Abteilung die sogar Angst vor Excel haben. Deswegen so leicht wie möglich...
Ich persönlich würde auch Privot machen,aber das
geht leider nicht.

Bild

Betrifft: AW: da ist mE ein Widerspruch in sich ...
von: ... neopa C
Geschrieben am: 11.11.2015 17:08:16
Hallo Dieter oder Peter oder wie immer Du Dich nennst.
... es gibt in dem Fall nicht einfacheres als eine PIVOTauswertung, warum geht diese also bei Euch nicht? Spricht da evtl. entgegen, dass dann 1 (in Worten: ein) Mausklick vorgenommen werden muss, wenn neue Daten eingelesen werden oder warum?
Wie viele Datensätze sind denn max auszuwerten?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: da ist mE ein Widerspruch in sich ...
von: Dieter
Geschrieben am: 11.11.2015 17:23:17
Hallo,
ca. 20.000Zeilen. Wenn es zu schwer ist, dann werde ich denen die Privot bei bringen.Dachte nur, daß eine Formel leichter wäre.

Bild

Betrifft: AW: nein, Formellösung ist nicht schwer, aber ...
von: ... neopa C
Geschrieben am: 11.11.2015 17:41:44
Hallo Dieter,
... gerade wenn 20000 Datensätze auszuwerten sind, muss damit gerechnet werden, das Du tausende verschiedene EAN-Nummern haben könntest. Da kann eine Formelauswertung ganz schön zäh werden. Deshalb rate ich Dir jetzt erst Recht zur PIVOTauswertung.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Liste ohne Duplikate"