Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Ersten 3 Werte mit Bedingung erfüllt

Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 09:03:53
Uli

Hallo,

ich hätte folgendes Problem:

Hier sind 2 Tabellen, die mein Problem veranschaulichen sollen:
https://www.herber.de/bbs/user/159571.jpg

Es geht darum, dass ich automatisch, die ersten 3 Typen angezeigt bekommen möchte, die kein "fac" als Art haben.

Es soll aber eine dynamische Formel sein, da die Typen täglich geändert werden und demnach auch das "fac" immer bei einer anderen.

Ich hoffe, dass mir hier jemand helfen kann :)

Danke schon mal im vorraus.

Lg uli

11
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 09:42:00
Pierre
Hallo Uli,

In D2:
=WENNFEHLER(INDEX(B:B;AGGREGAT(15;6;ZEILE($C:$C)/($C:$C="fac");ZEILE(B1)));"") 
und diese nach unten ziehen.

(Möglicherweise solltest du die Bereiche eingrenzen).

Gruß Pierre


AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 10:33:21
Uli
Hallo und vielen Dank für die rasche Antwort.

Ich bekomme allerdings leider eine leere Zelle. Kann das damit zusammenhängen, dass die "fac" durch eine Formel generiert wurde?

In der ursprünglichen Tabelle brauche ich nämlich die 3 letzten Werte, die nicht der Art "fac" entsprechen und ich habe mir die Tabelle "umgedreht", da ich dachte, dass es dann vielleicht leichter ist.

Das erste Bild zeigt meinen Versuch:
Userbild

Der würde zwar funktionieren, aber leider nur teilweise.

Das zweite Bild zeigt den Versuch mit der Aggregate-Formel. Hier bekomm ich leider nur ein leeres Feld.

Danke.


Anzeige
AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 10:45:32
Pierre
Hallo Uli,

kannst du bitte eine Beispielmappe hochladen, statt Bildern? Da erkennt man nämlich ungefähr gar nichts.

Übrigens, aber das hast du vielleicht selbst schon festgestellt, hatte ich das Kriterium =fac genannt, du wolltest ja das Gegenteil, also dann >"fac" in die Formel (das z. B. kann ich auf dem Bild nicht erkennen).

Ach ja: Ob das an der Berechnung liegt, weiß ich nicht.

Gruß Pierre


AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 10:47:54
Pierre
Versuch es vielleicht mal mit AGGREGAT(14;6;...), wenn du die 3 letzten haben willst.

Gruß Pierre


AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 11:20:44
Pierre
Willst du jetzt 101E, 102E, 103E als Ergebnis haben oder 107E, 106E, 105E?


AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 11:25:04
Uli
Immer die letzten 3 der ganz linken Tabelle, die nicht der Art "fac" entsprechen.

Die Formel sollte aber so funktionieren, dass wenn Typ und Art ändern, dass trotzdem die letzten 3 Typen die nicht "fac" sind, dort stehen.

Danke


AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 11:27:31
Uli
Also in der oberen Tabelle 107E, 106E und 105E

und in der unteren 108E, 106E und 105E.

Vielleicht sollte man auch erwähnen, dass die Anzahl an "fac" variieren kann (max.3), es aber auch gar keine "fac" geben kann (dann einfach die letzten 3).

Danke


Anzeige
AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 11:58:15
Pierre
Gib für die obere Tabelle diese Formel ein und ziehe sie 2 Zeilen runter:
=WENNFEHLER(INDEX(C:C;AGGREGAT(14;6;ZEILE($E$2:$E$11)/($E$2:$E$11>"fac");ZEILE(C2)));"")
Für die untere Tabelle analog:
=WENNFEHLER(INDEX(C:C;AGGREGAT(14;6;ZEILE($E$15:$E$24)/($E$15:$E$24>"fac");ZEILE(C2)));"")
Achtung, ich habe mich jetzt auf die linke Tabelle bezogen!

Passt das jetzt so?


Anzeige
AW: Ersten 3 Werte mit Bedingung erfüllt
13.06.2023 10:52:12
Rudi Maintaire
Hallo,
=INDEX($R$1:$R$1000;AGGREGAT(14;6;ZEILE($1:$1000)/($T$1:$T$1000&lt&gt"fac")*($R$1:$R$1000&lt&gt""); ZEILE(A1)))

Gruß
Rudi

322 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige