Mittelwert mit Bedingungen

Bild

Betrifft: Mittelwert mit Bedingungen
von: Anett
Geschrieben am: 28.07.2015 10:28:44

Hallo Ihr lieben Leute,
irgend etwas mach ich falsch:
hier die Beispieldatei
https://www.herber.de/bbs/user/99109.xlsx
Ich will die Mittelwert jeweils von Spalte a,b bzw. c berechnen. In Spalten, in denen keine Werte stehen, soll "0" als Ergebnis ausgegeben werden. Soweit funktioniert meine Formel.
Aber wenn jetzt einzelne Werte in Spalte b stehen, steh da immer noch "0". Nur wenn in der ersten Zeile auch ein Wert steht, wird es richtig berechnet.
ich danke Euch allen!
Anett

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Rudi Maintaire
Geschrieben am: 28.07.2015 10:44:48
Hallo,
ich sehe keine Mittelwert-Formel in der Datei.
Die Min-Formeln müssen als Matrixformeln eingegeben werden:
{=MIN(WENN(A1:A23=1;B1:B23;""))}
Gruß
Rudi

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Anett
Geschrieben am: 28.07.2015 10:55:37
Hallo Rudi,
hab gerade noch einma versucht meine Datei auf den Server zu legen - das funktioniert irgendwie nicht - die verändert dann den Inhalt (keine Ahnung was da passiert).
Ich versuch das dann mal hier her zu kopieren ( ; = Spaltentrenner)
2;;2
34;;34
4;5;3
3;3;3
3;;3
Mittelwerte
9,2;0;9
diese Formel hab ich in Spalte A (Ergebnis 9,2)
{=WENN(ISTLEER(A2:A6);0;MITTELWERT(A2:A6))}
ich danke Dir!
Anett

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Rudi Maintaire
Geschrieben am: 28.07.2015 11:11:23
Hallo,
was willst du erreichen?
Leere Zellen werden von Mittelwert() doch ohnehin ignoriert.
Oder sollen leere Zellen als 0 betrachtet werden?
{=MITTELWERT(WENN(ISTLEER(A2:A6);0;A2:A6))}
Gruß
Rudi

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Anett
Geschrieben am: 28.07.2015 11:59:48
ich will, dass wenn keine Werte in den Zellen stehen als "Mittelwert" 0 geschrieben wird (das funktioniert ja schon)
und ansonsten von den vorhandene Werten der Mittelwert berechnet wird (das funktioniert im Moment nur, wenn in der 1. Zeile auch was drin steht)
Die Leeren Zellen sollen nicht als "0" betrachtet werden
Gruß
Anett

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: SF
Geschrieben am: 28.07.2015 12:07:29
Hola,
als Array-Formel:

=MITTELWERT(WENN((A1:A23=1)*(B1:B23<>0);B1:B23;""))
Gruß,
steve1da

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Rudi Maintaire
Geschrieben am: 28.07.2015 12:14:50
Hallo,
ganz einfach:
=WENN(ANZAHL(A1:A10);MITTELWERT(A1:A10);0)
Gruß
Rudi

Bild

Betrifft: AW: Mittelwert mit Bedingungen
von: Anett
Geschrieben am: 29.07.2015 10:52:07
Hallo Rudi,
genial! Funktioniert wunderbar! Wäre ich nie drauf gekommen!
Danke Dir!
Gruß
Anett

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Mittelwert mit Bedingungen"