Immer den aktuellsten Wert außer "0"

Bild

Betrifft: Immer den aktuellsten Wert außer "0"
von: Jessica
Geschrieben am: 22.07.2015 10:01:14

Hallo zusammen,
ich stehe gerade ziehmlich auf dem Schlauch...
Ich möchte in die Zelle, in der die Fragezeichen stehen, eine Formel eingeben, so dass dort immer der aktuellste Stand (Betrag) angezeigt wird.
Beispiel: Ich habe einen Start-Betrag von 56.000,-
Jetzt gebe ich in Spalte A einen Betrag von 500,- ein, der von den 56.000,- abgezogen werden soll und das Ergebnis sowohl in der gleichen Zeile als auch unten in der Zelle mit den Fragezeichen angezeigt werden soll.
Nun gebe ich einen weiteren Betrag in Spalte A von z.B. 5.543,- ein. Dieser Betrag soll nun vom Vorergebnis abgezogen werden, so dass das aktuelle Ergebnis wieder in der gleichen Zeile und auch unten in der entsprechenden Zelle mit den Fragezeichen angezeigt wird usw.
Mir geht es jetzt speziell um die Formel, die ich in die unterste Zelle eintragen muss, damit immer automatisch der aktuelle Betrag angezeigt wird (außer, in einer Zelle steht mal eine Null). Hab es schon diverse Male mit WENN UND/ODER Funktion probiert - es klappt aber leider nicht so wirklich.
Viele lieben Dank schon mal für eure Hilfe.
https://www.herber.de/bbs/user/98997.xlsx

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: SF
Geschrieben am: 22.07.2015 10:11:41
Hola,
meinst du:

=C2-SUMME(B3:B10)
Gruß,
steve1da

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Jessica
Geschrieben am: 22.07.2015 10:20:14
Jaaaa, hurraaa! Mensch, da hatte ich aber wirklich ein dickes fettes Brett vor dem Kopf!
Vielen Dank, steve1da
Gruß,
Jessica

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Jessica
Geschrieben am: 22.07.2015 10:26:27
Nee, klappt leider doch nicht. Ich muss wohl meine Beispieldatei noch mal ändern, damit das Problem deutlich wird. Sorry...
Trotzdem lieben Dank für die Hilfe.
Gruß,
Jessica

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Matthias L
Geschrieben am: 22.07.2015 10:16:23
Hallo

 ABC
1Datum Startbetrag:
2  56.000,00 €
321.01.2015500,00 €55.500,00 €
4 0,00 €55.500,00 €
530.04.20155.543,00 €49.957,00 €
606.05.20150,00 €49.957,00 €
712.05.20156.547,00 €43.410,00 €
822.06.20150,00 €43.410,00 €
9 0,00 €43.410,00 €
1016.07.20150,00 €43.410,00 €
11 Aktueller Stand:43.410,00 €

Formeln der Tabelle
ZelleFormel
C3=WENN(B3>0;C2-B3;C2)
C4=WENN(B4>0;C3-B4;C3)
C5=WENN(B5>0;C4-B5;C4)
C6=WENN(B6>0;C5-B6;C5)
C7=WENN(B7>0;C6-B7;C6)
C8=WENN(B8>0;C7-B8;C7)
C9=WENN(B9>0;C8-B9;C8)
C10=C8-B10
C11{=MIN(WENN(C3:C10>0;C3:C10))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Matthias L
Geschrieben am: 22.07.2015 10:33:58
Hallo
Korrektur:
https://www.herber.de/bbs/user/99003.xlsx

 C
1199,00 €

Formeln der Tabelle
ZelleFormel
C11{=MIN(WENN(B3:B10>0;C3:C10))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Jessica
Geschrieben am: 22.07.2015 11:00:16
Hi Matthias,
ich hab das jetzt noch nicht probiert mit deiner Formel, habe aber noch mal meine Original-Datei (mit geänderten Namen und Beträgen) drangehängt. Vielleicht wird dadurch mein Problem etwas deutlicher. Hab festgestellt, dass ich nicht nur die Formel in der untersten Zeile nicht hinkriege, sondern die dazwischen auch nicht.... :o(
Lediglich die erste Zeile stimmt. Dort wird der eingegebene Betrag vom Anfangsbestand des jeweiligen Kontos abgezogen. Aber dann ???
Gruß,
Jessica
https://www.herber.de/bbs/user/99005.xlsx

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: SF
Geschrieben am: 22.07.2015 11:26:28
Hola,
in E2:

=WENN($C5=E$2;E$3-SUMMEWENN($C$5:$C5;E$2;$D$5:$D5);0)
Diese Formel nach rechts und nach unten kopieren. In N3 musst du hinter "Land" das Leerzeichen entfernen.
Die Summenformeln schaffst du jetzt bestimmt alleine ;)
Gruß,
steve1da

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Matthias L
Geschrieben am: 22.07.2015 11:48:38
Hallo
https://www.herber.de/bbs/user/99008.xlsx
Gruß Matthias

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Jessica
Geschrieben am: 22.07.2015 13:11:24
Wow, das geht! :O)))) Auf die Idee mit der Formel =MIN... wäre ich aber auch im Leben nicht gekommen. Ich sag ja: Brett vorm Kopf. Und die anderen Formeln dazwischen: Da war ich schon nah dran. Aber manchmal denke ich einfach zu kompliziert...
1000-Dank noch mal für die Hilfe.
Viele Grüße
Jessica

Bild

Betrifft: AW: Immer den aktuellsten Wert außer "0"
von: Matthias L
Geschrieben am: 22.07.2015 11:05:27
Hallo
Hier nochmal mein überarbeitetes Beispiel:
https://www.herber.de/bbs/user/99006.xlsx
In der Datei sind auch Gültigkeitsregeln und bedingte Formatierung.
Übrigens klappt doch die Formel von Steve ganauso(ist sogar einfacher)
Gruß Matthias

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Was läuft falsch"