MIN / MAX /Mittelwert ohne Ausreißer



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: MIN / MAX /Mittelwert ohne Ausreißer
von: Jens Bartels
Geschrieben am: 05.06.2002 - 13:11:50

Ich muß aus einer Liste von Werten die MIN / MAX / Mittel-Werte ermitteln, ohne daß Ausreißer, die sehr stark von den anderen Werten abweichen, berücksichtigt werden. Dabei sollen die Ausreißer allerdings nicht gelöscht werden. Von Hand gehts doch sehr langsam. Kennt ihr einen einfacheren Weg??

nach oben   nach unten

Re: MIN / MAX /Mittelwert ohne Ausreißer
von: Harald Kapp
Geschrieben am: 05.06.2002 - 14:06:37

Hallo Jens,
Du könntest wie folgt vorgehen:
1) Definiere, was sind Ausreißer?
Z.B.: Alles <0,5*Mittelwert und alles >1,5*Mittelwert (musst Du natürlich an Deine Bedürfnise anpassen.
2) Berechne Min und Max mittels einer Matrix Formel (Eingabe in C15 und C16 mit CTRL-SHIFT-ENTER abschließen, siehe den Thread zu CSE-Formeln weite unten im Forum)

Beispiel:

MS Excel von Harald Kapp an Jens Bartels
 ABCD
11   
22   
33   
42   
53   
67   
7-4   
8-2   
91   
105   
11.   
12.   
13.   
14.   
151,80=MITTELWERT(A1:A10)1=MIN(WENN(A1:A10
160,9=A15*0,52,7=MAX(WENN(A1:A10>A16;A17;A1:A10))
172,7=A15*1,5  


Hier noch mal die Formeln, weil in der Tabelle schlecht lesbar:
C15 = {=MIN(WENN(A1:A10C16 = {=MAX(WENN(A1:A10>A16;A17;A1:A10))}
Die geschweiften Klammern nicht eingeben, die setzt Excel bei SHIFT-CTRL-ENTER selbst.

Gruß Harald


 nach oben

Beiträge aus den Excel-Beispielen zum Thema "ersetzen"