Herbers Excel-Forum - das Archiv

Minimum/Maximum auslesen, Mittelwert

Bild

Betrifft: Minimum/Maximum auslesen, Mittelwert
von: Barbara Kelb

Geschrieben am: 02.01.2007 13:52:27
Hallo ich habe folgende Probleme,
1. Ich habe in einer Spalte A verschiedene Werte 5, 8, 9, 4 in der nebenstehenden Spalte B soll jetzt neben der Zeile mit dem niedrigsten Wert also der 4 "Minimum" erscheinen. Neben der höchsten Zahl (der 9) "Maximum". Die restlichen Zeilen sollen leer bleiben.
2. Problem: Ich habe eine Spalte A mit verschiedenen Werten
Eine Spalte B in der Namen (Müller, ...) stehen, denen diese Werte zugeordnet
werden sollen.
Eine Spalte C in der der Mittelwert angezeigt werden soll.
In Spalte C sind die Namen (Müller, Meier, Huber, Klaus) aufgelistet. Jetzt soll aus, zu den Namen(Spalte B)zugehörigen Beträgen (Spalte A) der Mittelwert berechnet werden.
Wäre sehr nett, wenn mir jemand behilflich sein könnte.
Vielen Dank!!
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Thomas

Geschrieben am: 02.01.2007 14:02:06
Zu 1)
Wenn die Reihe in Zeile 1 beginnt, dann ist in Zelle B1 folgende Formel hineinzuschreiben:
=WENN(A1=MIN(A:A);"Minimum";WENN(A1=MAX(A:A);"Maximum";""))
Diese Formel dann nach unten kopieren, sodass aus A1 A2 wird usw.
Zu 2)
Kapier ich nicht. Die Beschreibung ist etwas wirr... Beispiel?
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Barbara

Geschrieben am: 02.01.2007 14:35:17
Vielen Dank für die schnelle Antwort. Die Formel funktioniert super!
Zu meinem 2. Problem nochmal.
Spalte A: Durchschnittlicher Benzinverbrauch
8
9
6
9
8
8
7
Spalte B: Marke
Shell
Aral
Shell
Esso
Esso
Aral
Shell
Spalte C: Mittelwert Verbrauch
Aral
Esso
Shell
Werte in Zeile 1 von Spalte A und B gehören zusammen. Es wurde bei Shell getankt und der durchschnittliche Verbrauch ist 8 Liter, 2. Zeile: Bei Aral getankt 9 Liter Verbrauch,...
Nun gibt es eine Spalte C in der jede Benzinmarke nur einmal auftaucht.
Es sollen die jeweiligen, zu der Benzinmarke gehörigen Werte aus Spalte A addiert werden
und daraus dann der Mittelwert berechnet werden.
Für Shell: (8 + 6 + 7 )/ 3
Für Esso: (9 + 8)/ 2
Hoffentlich habe ich mich diesmal verständlicher ausgedrückt.
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Barbara

Geschrieben am: 02.01.2007 14:38:10
Vielen Dank für die schnelle Antwort. Die Formel funktioniert super!
Zu meinem 2. Problem nochmal.
Spalte A: Durchschnittlicher Benzinverbrauch
8
9
6
9
8
8
7
Spalte B: Marke
Shell
Aral
Shell
Esso
Esso
Aral
Shell
Spalte C: Mittelwert Verbrauch
Aral
Esso
Shell
Werte in Zeile 1 von Spalte A und B gehören zusammen. Es wurde bei Shell getankt und der durchschnittliche Verbrauch ist 8 Liter, 2. Zeile: Bei Aral getankt 9 Liter Verbrauch,...
Nun gibt es eine Spalte C in der jede Benzinmarke nur einmal auftaucht.
Es sollen die jeweiligen, zu der Benzinmarke gehörigen Werte aus Spalte A addiert werden
und daraus dann der Mittelwert berechnet werden.
Für Shell: (8 + 6 + 7 )/ 3
Für Esso: (9 + 8)/ 2
Hoffentlich habe ich mich diesmal verständlicher ausgedrückt.
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Rudi Maintaire
Geschrieben am: 02.01.2007 14:55:23
Hallo,
=summewenn(B:B;B1;A:A)/Zählenwenn(b:b;b1)
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Thomas

Geschrieben am: 02.01.2007 14:56:45
Hallo Barbara,
8 Shell Aral 8,5
9 Aral Esso 8,5
6 Shell Shell 7
9 Esso
8 Esso
8 Aral
7 Shell
Formel für D1: =SUMMEWENN(B:B;C1;A:A)/ZÄHLENWENN(B:B;C1)
Diese Formel dann runterkopieren.
Antwort wäre nett. Schönen Tag noch!
Thomas
Bild

Betrifft: AW: Minimum/Maximum auslesen, Mittelwert
von: Barbara

Geschrieben am: 03.01.2007 16:25:14
Hallo Thomas,
Hallo Rudi,
Vielen, vielen Dank für die Formel!!! Das Einsetzen war dann nur noch eine Sache von Sekunden. Formel funktioniert so wie ich mir das vorgestellt habe.
Ihr habt mir viele Stunden des herumtüfftelns erspart.
Barbara
 Bild
Excel-Beispiele zum Thema "Minimum/Maximum auslesen, Mittelwert"
Rechnungsnummer in Registry eintragen, auslesen, löschen Mittelwert ohne Nullwerte
Bedingter Mittelwert Aus einer Reihe von 10-minütigen Messungen h-Mittelwerte auslesen
Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel Berechnung von Zeitspanne und Mittelwert
Mittelwert aus den 6 höchsten Werten in Spalte A ermitteln