Microsoft Excel

Herbers Excel/VBA-Archiv

Summe nicht zusammenhängender Werte mit Bedingung und #NV

Betrifft: Summe nicht zusammenhängender Werte mit Bedingung und #NV von: Anna
Geschrieben am: 31.01.2020 20:35:35

Hallo zusammen,


ich habe ein Artikel, der auf mehreren Stellplätzen liegt. Desweiteren gibt es eine Unterscheidung zwischen großen und kleinen Stellplätzen. Alles ist in Spalten angeordnet. Nun möchte ich in Spalte Q die Gesamtmenge der großen Stellplätze und in Spalte R die Gesamtmenge der kleinen Stellplätze berechnen. Auch kann es sein dass in manchen Spalten ein #NV Fehler auftaucht. Kann mir hier jemand mit einer Formel weiterhelfen?

Bis jetzt komme ich nur auf die Idee jeden Stellplatz einzeln mit einer Wenn-Formel zu berechnen und anschließend zu addieren, jedoch ist das sehr aufwendig und es sind viele zusätzliche Spalten nötig.


Danke


https://www.herber.de/bbs/user/134885.xlsx

Betrifft: AW: Summe nicht zusammenhängender Werte mit Bedingung und #NV
von: onur
Geschrieben am: 31.01.2020 21:12:34

Kein Wunder - Dein Tabellenaufbau ist Murks.
Wen du sie so aufbaust, hast du null Probleme damit:
https://www.herber.de/bbs/user/134887.xlsx

Betrifft: =SUMMEWENN(C2:O2;"groß";D2:P2)
von: WF
Geschrieben am: 31.01.2020 21:32:26

und
=SUMMEWENN(C2:O2;"klein";D2:P2)

WF

Betrifft: AW: =SUMMEWENN(C2:O2;"groß";D2:P2)
von: Anna
Geschrieben am: 01.02.2020 17:37:22

Danke,

hätte nicht gedacht, dass das so leicht ist.

Betrifft: AW: =SUMMEWENN(C2:O2;"groß";D2:P2)
von: onur
Geschrieben am: 01.02.2020 17:43:38

Dein Konzept ist trotzdem Murks - hast nur Glück, dass das eine ein Text und das andere eine Zahl ist.
Wenn du jetzt statt "klein" und "gross" z.B. max. Palettenhöhe hättest, ginge es nicht, da die Formel nicht zw. 120 cm und 120 Stck unterscheiden könnte.
Du wirst später wahrscheinlich noch mehr Probleme bei diesem Konzept bekommen.

Beiträge aus dem Excel-Forum zum Thema "Summe nicht zusammenhängender Werte mit Bedingung und #NV"