Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit Datum --> #NV | Herbers Excel-Forum


Betrifft: Summenprodukt mit Datum --> #NV von: Katharina
Geschrieben am: 23.11.2009 15:52:53

Hallo zusammen,

ich versuche gerade eine Summenproduktformel zusammen zu setzen.

Die einzelnen Bestandteile funktionieren einzeln (in unterschiedlichen Zellen berechnet) alle einwandfrei.

{=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*1)}
{=SUMMENPRODUKT(($CS$1:$CS$5000=$C$116)*1)}
{=SUMMENPRODUKT(($CB$2:$CB$5000>=B114)*1)}
~f~
In Zelle B114 steht ein Datum (01.07.2009). Habe es auch schon mit DATWERT("01.07.2009") probiert.

Wenn ich jetzt alle drei Bestandteile hintereinander schalte, dann kommt #NV sobald ich die Datumskomponente einfüge.

Wie kann das sein? Einzeln funktioniert die Datumsabfrage, nur im Zusammenhang wird #NV daraus.
~f~
{=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*($CS$1:$CS$5000=$C$116)*($CB$2:$CB$5000>=B114))}

Jegliche Tipps sind willkommen.

Danke,
Katharina

  

Betrifft: + statt * ...und... von: {Boris}
Geschrieben am: 23.11.2009 15:55:50

Hi Katharina,

...die Bereiche müssen ALLE die selbe Größe haben - guck mal bei $CB$2:$CB$5000...

Grüße Boris


  

Betrifft: AW: + statt * ...und... von: Katharina
Geschrieben am: 23.11.2009 15:59:15

Hallo Boris,

das ist ja zu blöde!!!

Manchmal braucht man halt einfach noch ein paar Augen, die auf das Problem schauen.

Vielen Dank,
Katharina


  

Betrifft: Unterschiedlich grosse Bereiche ! von: NoNet
Geschrieben am: 23.11.2009 15:58:28

Hallo Katharina,

in der SUMMENPRODUKT-Funktion müssen alle zu überprüfenden Bereiche gleich groß sein !

In Deinem Fall bestehen die ersten beiden Bereiche aus 5000 Zeile (Zeile 1 bis 5000), der letzte Bereich aus "nur" 4999 Zeilen (Zeile 2 bis 5000).

So sollte es klappen :
=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*($CS$1:$CS$5000=$C$116)*($CB$1:$CB$5000>=B114))

PS : Die SUMMENPRODUKT-Funktion musst Du NICHT per Strg+Shift+ENTER bestätigen, hier genügt nur ENTER !

Gruß, NoNet


  

Betrifft: AW: Unterschiedlich grosse Bereiche ! von: Katharina
Geschrieben am: 23.11.2009 16:10:22

Hallo NoNet,

hatte irgendwann mal gelesen, dass man SUMMENPRODUKT als Array-Formel abschließen muss. Seit dem mache ich das so.

Kannst du vielleicht erklären in welchen Fällen das notwendig ist und wann nicht?

Vielen Dank auf jeden Fall schon mal für die Lösung meines Problems


  

Betrifft: SUMMENPRODUKT ist "von Hause aus" MATRIX-Funktion von: NoNet
Geschrieben am: 23.11.2009 16:24:41

Hallo Katharina,

grundsätzlich ist es richtig, dass man Funktionen per STRG+Shift+ENTER bestätigen muss, wenn man diese als MATRIX-Funktionen verwenden möchte.

Speziell im Fall von SUMMENPRODUKT ist das jedoch nicht notwendig, da diese bereits von der Konzeption her als MATRIX-Funktion ausgelegt ist, also auch bei ENTER als MATRIX-Funktion fungiert.

Es gibt lediglich einige wenige Fälle, in denen darin verschachtelte Funktionen die Bestätigung per Strg+Shift+Enter benötigen, um die notwendige Wertematrix zu liefern - aus dem Hangelenk geschüttelt kann ich dafür jedoch kein Beispiel konstruieren (vielleicht kann das unser Matrix-Guru {Boris} ? ;-).

Gruß, NoNet