Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Summenprodukt mit Datum --> #NV

Summenprodukt mit Datum --> #NV
Katharina
Hallo zusammen,
ich versuche gerade eine Summenproduktformel zusammen zu setzen.
Die einzelnen Bestandteile funktionieren einzeln (in unterschiedlichen Zellen berechnet) alle einwandfrei.
{=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*1)}
{=SUMMENPRODUKT(($CS$1:$CS$5000=$C$116)*1)}
{=SUMMENPRODUKT(($CB$2:$CB$5000>=B114)*1)}
~f~
In Zelle B114 steht ein Datum (01.07.2009). Habe es auch schon mit DATWERT("01.07.2009") probiert.
Wenn ich jetzt alle drei Bestandteile hintereinander schalte, dann kommt #NV sobald ich die Datumskomponente einfüge.
Wie kann das sein? Einzeln funktioniert die Datumsabfrage, nur im Zusammenhang wird #NV daraus.
~f~
{=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*($CS$1:$CS$5000=$C$116)*($CB$2:$CB$5000>=B114))}
Jegliche Tipps sind willkommen.
Danke,
Katharina

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Benutzer
Anzeige
+ statt * ...und...
23.11.2009 15:55:50
{Boris}
Hi Katharina,
...die Bereiche müssen ALLE die selbe Größe haben - guck mal bei $CB$2:$CB$5000...
Grüße Boris
AW: + statt * ...und...
23.11.2009 15:59:15
Katharina
Hallo Boris,
das ist ja zu blöde!!!
Manchmal braucht man halt einfach noch ein paar Augen, die auf das Problem schauen.
Vielen Dank,
Katharina
Unterschiedlich grosse Bereiche !
23.11.2009 15:58:28
NoNet
Hallo Katharina,
in der SUMMENPRODUKT-Funktion müssen alle zu überprüfenden Bereiche gleich groß sein !
In Deinem Fall bestehen die ersten beiden Bereiche aus 5000 Zeile (Zeile 1 bis 5000), der letzte Bereich aus "nur" 4999 Zeilen (Zeile 2 bis 5000).
So sollte es klappen :
=SUMMENPRODUKT(($C$1:$C$5000=$AC119)*($CS$1:$CS$5000=$C$116)*($CB$1:$CB$5000>=B114))
PS : Die SUMMENPRODUKT-Funktion musst Du NICHT per Strg+Shift+ENTER bestätigen, hier genügt nur ENTER !
Gruß, NoNet
Anzeige
AW: Unterschiedlich grosse Bereiche !
23.11.2009 16:10:22
Katharina
Hallo NoNet,
hatte irgendwann mal gelesen, dass man SUMMENPRODUKT als Array-Formel abschließen muss. Seit dem mache ich das so.
Kannst du vielleicht erklären in welchen Fällen das notwendig ist und wann nicht?
Vielen Dank auf jeden Fall schon mal für die Lösung meines Problems
SUMMENPRODUKT ist "von Hause aus" MATRIX-Funktion
23.11.2009 16:24:41
Hause
Hallo Katharina,
grundsätzlich ist es richtig, dass man Funktionen per STRG+Shift+ENTER bestätigen muss, wenn man diese als MATRIX-Funktionen verwenden möchte.
Speziell im Fall von SUMMENPRODUKT ist das jedoch nicht notwendig, da diese bereits von der Konzeption her als MATRIX-Funktion ausgelegt ist, also auch bei ENTER als MATRIX-Funktion fungiert.
Es gibt lediglich einige wenige Fälle, in denen darin verschachtelte Funktionen die Bestätigung per Strg+Shift+Enter benötigen, um die notwendige Wertematrix zu liefern - aus dem Hangelenk geschüttelt kann ich dafür jedoch kein Beispiel konstruieren (vielleicht kann das unser Matrix-Guru {Boris} ? ;-).
Gruß, NoNet
Anzeige

305 Forumthreads zu ähnlichen Themen


Hallo zusammen,
ich möchte gerne mittels einer Auswahlliste dem Benutzer die Chance geben
eine Auswahl zu treffen (siehe Tabelle im Anhang).
Bei "Alu" ist das auch gar kein Problem, aber bei "Stahl" komme ich nicht weiter.
Die Preisstaffelungen befinden sich im 2. Tabellenblatt...
Anzeige

Hallo Forumsgemeinde,
ich arbeite mit einer englischen Excelversion und erst beim Öffnen in einer deutschen Version ist mir ein Fehler aufgefallen. Im Englischen wird als Fehlercode #N/A ausgegeben, was im Deutschen #NV entspricht. Nun habe ich leider in einer SUMMEWENN-Formel (SUMIF) die B...

Hallo,
ich habe eine Formel gefunden die eine Summe trotz Bezugsfehler bildet.
SUMMEWENN(O2:O500;"#BEZUG!")
Doch da muss ich den Fehler genau angeben. Kennt jemand eine Variante bei der alle Fehler ignoriert werden?
Gruß Joni
Anzeige

Hallo,
wie kann ich diesem code sagen, das er aussteigen soll wenn er keine Fehlerwerte mehr findet?
Dim x As Long
Application.ScreenUpdating = False
For x = Cells(Rows.Count, 1).End(xlUp).Row To 1 Step -1
If Cells(x, 1) = CVErr(xlErrValue) Then Rows(x).Delete
Next x
...

Hallo Excel Profis,
ich verwende die Summenprodukt-Formel um Summenwerte nach Monaten, und anderen Kriterien zu kumulieren:
'SUMMENPRODUKT(($H$7:$AQ$7<=$B$4)*($H$8:$AQ$8="PLAN")*($H9:$AQ9))
Jedoch haben Monate, die noch in der Zukunft liegen, keine Werte (#BEZUG im Tabellenblatt)...

Guten Tag zusammen
Ich möchte in einer Spalte die Summe aller Werte ermitteln, die nur einen Wert enthalten und nicht NV.
Mit Summe() kommt immer NV.
Vielen Dank für Eure hilfe und einen schönen Tag.
Gruss
Urs

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige