SUMMEWENN mit Mehrfachbedingung

Bild

Betrifft: SUMMEWENN mit Mehrfachbedingung von: Fabienne
Geschrieben am: 22.02.2005 11:47:50

Hi,

gibt es ne Möglichkeit bei SUMMEWENN eine Mehrfachbedingung reinzubringen:

Z.B. Es sollen nur alle Werte summiert werden, die, a) großer als 5 sind und b) nicht älter als 3 Tage sind. Anmerkung: Es wird das Datum des Datensatzes in einer Spalte mitgeführt.

Grüße in "Weball"!

Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: OttoH
Geschrieben am: 22.02.2005 11:55:29

Hallo Fabienne,

schau mal hier nach: http://www.excelformeln.de/formeln.html?welcher=61

Gruß OttoH


Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: HermannZ
Geschrieben am: 22.02.2005 11:58:06

Hallo Weball,

ein Beispiel;
LeerB
 ABC
5   
6317.02.200515
7418.02.2005 
8519.02.2005 
9420.02.2005 
10721.02.2005 
11822.02.2005 
12   
Formeln der Tabelle
C6 : {=SUMME((B6:B11<=HEUTE())*(B6:B11>=HEUTE()-3)*(A6:A11>5)*A6:A11)}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: Fabienne
Geschrieben am: 22.02.2005 12:29:08

Hi,

geht es auch, dass man 3 Spalten in Abhängikeit voneinander mit einander verrechnet?
Folgendes:
Es geht um eine Rechnungsübersicht.
Es gibt in
- Blatt 1 - Spalte A Kundennummer
- Blatt 1 - Spalte B den Wert der Rechnung in EUR

- Blatt 2 - Splate C Kundennummer
- Blatt 2 - Spalte D Zahlungseingang in EUR

- Blatt 1 - Spalte E soll dann der Restbetrag der in dieser Zeile stehenden Rechnung stehen

Achtung: Es kann eben sein, dass ein Kunde eine "Abschlagszahlung" macht, die NICHT dem Rechnungsbetrag entspricht. Auch kann es sein, dass der Kunde mehrere Zahlungen für eine Rechnung unternimmt. Daher zwei verschiedene Tabellenblätter.
Der Restbetrag sollte dann aber nur bis maximal 0EUR runtergezählt werden. Sobald dieser Wert erreicht ist, wird die Zeilenhintergrundfarbe auf Grün geschaltet.

Daran beiße ich mir seit Tagen die Zähne aus.....

Vielleicht hat jemand eine einfachere Lösung/Idee!


Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: OttoH
Geschrieben am: 22.02.2005 13:58:16

Hallo Fabienne,

Du wirfst hier, wenn ich es richtig sehe, mehrere Probleme durcheinander.
Mach doch bitte für jede Frage einen Thread auf.

Gruß OttoH


Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: HermannZ
Geschrieben am: 22.02.2005 16:38:28

Hallo Fabienne,

sorry habe erst jetzt gesehen das du dich gemeldet hast, zu deiner Frage " ja"

Ein Beispiel;

LeerB
 ABCDEF
27      
28Kd.Nr.:R.BetragKd.Nr.:gezahltges.Kd. Nr.:Restbetrag
29123456123,56 €12345634,56 €123456289,00 €
30234567234,56 €234567234,56 €  
31345678345,67 €345678345,67 €  
32123456456,78 €123456256,78 €  
33      
Formeln der Tabelle
F29 : {=SUMME((A29:A35=E29)*(B29:B35))-SUMME((C29:C35=E29)*(D29:D35))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: SUMMEWENN mit Mehrfachbedingung von: Gert Seler
Geschrieben am: 23.02.2005 12:29:34

Hallo Fabienne,
Name_Blatt_01 =Rechnung; Blatt_02 =Zahlung (Blatt_umbennen). Spalten wie von Dir
angegeben.
Dann sieht Formel in (Blatt_01) Rechnung_E2 wie folgt aus :

'=WENN(B2-Zahlung!D2=0;0;B2-Zahlung!D2)

Erklärung: Wenn RechnungsBetrag - Minus Zahlung!D2 =Null; Dann 0=Null; Sonst
RechnungsBetrag - Minus Zahlung.

mfg
Gert


Bild


Betrifft: -> SUMMENPRODUKT von: UweN
Geschrieben am: 22.02.2005 11:58:40

Hi Fabienne,

ja, das geht mit der Funktion SUMMENPRODUKT.

Zum Beispiel:
=SUMMENPRODUKT((A1:A4>HEUTE()-3)*(A1:A4<HEUTE()+5)*B1:B4)

(erstze > durch das Größer - Zeichen; < durch das Kleinerzeichen)

Annahme:
Datum steht in Spalte A; Zeile 1 - 4
Wert stehen in Spalte B

Viele Grüße
Uwe


Bild


Betrifft: AW: -> SUMMENPRODUKT von: Gert Seler
Geschrieben am: 22.02.2005 13:49:23

Hallo Fabienne,
mit "Bedingter Formatierung" erreichst Du den Wechsel der HintergrundFarbe.
Markiere die Spalte "E", dann "Format" --->"Bedingte Formatierung"
wählen E1 größer 0; "HintergrundFarbe" auf "rot" und die Schrift auf "weiß" ändern.
Nun 2te Formatierung : E1 gleich 0; "HintergrundFarbe" ="grün" und evtl Schrift-
farbe ändern. Mit "OK" zurück. Die Adresse "E1" bitte anpassen.

mfg
Gert



 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN mit Mehrfachbedingung"