Microsoft Excel

Herbers Excel/VBA-Archiv

Werte summieren wenn Kriterieum erfüllt ist | Herbers Excel-Forum


Betrifft: Werte summieren wenn Kriterieum erfüllt ist von: Andre
Geschrieben am: 07.12.2009 16:20:37

Hallo,

hab ne kleine Frage.

ich bekomme immer #WERT! raus

=SUMME(WENN(F12:F1000=2681;B12:C1000;""))

Mein Ziel ist, die Werte in € zu summieren, die sich in Feld B12 bis C1000 befinden, wenn auf gleicher Höhe in einer anderen Zeile der Wert oder die Zahl 2681 steht.

was mache ich falsch?
Habs auch schon mit dem Summenprodukt versucht, aber da ist doch bestimmt nur ein taktischer Fehler enthalten oder?

gruss André

  

Betrifft: AW: Werte summieren wenn Kriterieum erfüllt ist von: werni
Geschrieben am: 07.12.2009 16:28:56

Hi Andre

Formel mit Ctrl + Shitf + Enter abschliessen.
https://www.herber.de/bbs/user/66410.htm

Gruss Werner


  

Betrifft: geht auch mit Summewenn von: werni
Geschrieben am: 07.12.2009 16:31:28

Hi Andre

=SUMMEWENN(F:F;2681;B:B)

Gruss Werner


  

Betrifft: AW: geht auch mit Summewenn von: Andre
Geschrieben am: 07.12.2009 16:34:46

Hallo,

=SUMMEWENN(F:F;2681;B:C) funktioniert irgendwie nur halb, die Werte aus C werden nicht gezählt

auch wenn ich =SUMMEWENN(F12:F13;2681;B12:C13) eingebe, geht es nicht.


  

Betrifft: AW: geht auch mit Summewenn von: Dominik
Geschrieben am: 07.12.2009 16:36:19

in dem Beispiel fehlt doch auch komplett die abfrage ob irgendwas gleich etwas ist oder kleiner größer ...


  

Betrifft: AW: geht auch mit Summewenn von: Dominik
Geschrieben am: 07.12.2009 16:38:06

SRY mein fehler ... Nicht richtig gelesen schnell meine Antwort ignorieren


  

Betrifft: AW: geht auch mit Summewenn von: Dominik
Geschrieben am: 07.12.2009 16:39:29

So nun hab ichs :D nimm beides mal den gleichen Bereich den du Abfragen möchtest ...


  

Betrifft: AW: geht auch mit Summewenn von: Andre
Geschrieben am: 07.12.2009 16:42:51

Hallo,

was genau meinst du mit dem Bereich?


  

Betrifft: AW: geht auch mit Summewenn von: Dominik
Geschrieben am: 07.12.2009 16:48:10

Ich hab es gerade selber mal getestet ... und ich glaub ich weiss auf welches Problem du stößt ... er soll aus 2 Spalten zusammenzählen ... aber er nimmt in dem Fall nur die aus der ersten Spalte ...

ich hab es nun mal so gelöst ... pro spalte eine abfrage

=(SUMMEWENN(O16:O20;12;Q16:Q20))+(SUMMEWENN(O16:O20;12;R16:R20))

und dann die 2 Werte addieren ... sicher nicht die beste Lösung aber die einzige die mir gerade einfällt


  

Betrifft: AW: geht auch mit Summewenn von: Dominik
Geschrieben am: 07.12.2009 16:52:38

=(SUMMEWENN(F12:F1000;2681;B12:B1000))+(SUMMEWENN(F12:F1000;2681;C12:C1000))

wäre wohl die Formel die du brauchst

sag dann Bescheid ob es so gemeint war, was du wolltest ;)

Dominik


  

Betrifft: AW: geht auch mit Summewenn von: Andre
Geschrieben am: 07.12.2009 16:58:11

Hallo,
ja die funktioniert super danke

Weiss denn noch jemand eine kürzere Lösung?

Wenn ich das nun über 2 Tabellenblätter mache und mit $ am Anfang wird die Formel schnell unübersichtlich.

danke dennoch schonmal

gruss


  

Betrifft: Klartext von: werni
Geschrieben am: 07.12.2009 17:27:18

Hi Andre

Nun mal Klartext. Da wir deine Arbeitmappe nicht kennen, musst du uns genau sagen, welche Spalten von Tabelle1 und welche von Tabelle2 zu vergleichen sind.

Kannst ja mal ein abgespeckte Mappe hochladen und genau beschreiben.

Gruss Werner


  

Betrifft: AW: geht auch mit Summewenn von: werni
Geschrieben am: 07.12.2009 19:46:51

Hi Andre

Ein Versuch.
Tabelle1 Zelle H1 ist das Suchobjekt das in Tabelle1 in Spalte F vorkommt.
In Tabelle1 sind es Spalten B und C.
In Tabelle2 sind es Spalten E und F.
https://www.herber.de/bbs/user/66413.htm

Gruss Werner


Beiträge aus den Excel-Beispielen zum Thema "Werte summieren wenn Kriterieum erfüllt ist"