VBA-Programmierung in Microsoft Excel

Tutorial: Excel-Beispiele

Zahlen unter Berücksichtigung von Monat und Jahr summieren

Gruppe

Matrix

Bereich

Matrixfunktion

Thema

Zahlen unter Berücksichtigung von Monat und Jahr summieren

Problem

Die Einträge zu einem jeweiligen Monat im Bereich A1:A100 sollen unter Berücksichtigung des Jahres gezählt werden.

Lösung

Matrixformel: =SUMME((MONAT(A1:A100)=B1)*(JAHR(A1:A100)=C1)*1)




StandardModule: basMain

Sub Berechnung()
    Dim rngAct As Range
    For Each rngAct In ActiveSheet.UsedRange
        Select Case CStr(rngAct.Value)
            Case "1"
                rngAct = rngAct * 12
            Case "3"
                rngAct = rngAct * 8
            Case "4"
                rngAct = rngAct * 6
        End Select
    Next rngAct
End Sub

    


Beiträge aus dem Excel-Forum zu den Themen Matrix und Matrixfunktion