Microsoft Excel

Herbers Excel/VBA-Archiv

Subtraktion bis Wert erreicht (Zirkelbezug) | Herbers Excel-Forum


Betrifft: Subtraktion bis Wert erreicht (Zirkelbezug) von: Tom
Geschrieben am: 27.10.2008 11:54:40

Hallo,

ich probiere mich seit 2 Tagen mit der Problematik Zirkelbezug. Ich möchte diese Funktion benutzen, um so lange Werte aus einigen Zellen zu subtrahieren, bis der in einer anderen Zelle definierte maximale Wert erreicht ist.

Hintergrund:
Für eine gesonderte Auszahlung steht mir ein gewisser Topf zur Verfügung. Auf Grund von Berechnungen kann es aber sein, dass die berechnete Auszahlung (Punktesystem) höher ausfällt als der Topf im eigentlichen ist.
Nun möchte ich jedem Mitarbeiter von seiner Auszahlung soviel abziehen, bis der Topf nicht mehr überschritten wird.
WICHTIG: Wichtig ist jedoch, dass ich das abziehen (subtrahieren) nicht gleichmäßig machen kann! Da jeder unterschiedlich in den Topf einzahlt, muss der Abzug bis zur Topfgrenze auch Prozentual geschehen.

Um es einfacher zu machen, hab ich mal eine Datei angehangen. Da ist auch der wert zu sehen, mit welchem in den Topf eingezalt worden ist (Prozentwert).

Am liebsten würde mir eine Lösung mit einer Formel gefallen. Allerdings vermute ich mal, dass es ohne VBA nicht ohne weiteres geht.

P.S. Mir ist allerdings klar, dass bei so einer Berechnung evtl. eine kleine Restsumme übrig bleiben wird, die sich nicht auf die Mitarbeiter verteilen läst. Das kann vernachlässigt werden...wird ja nicht so viel sein.

Vielen Dank für eure Hilfe....

Der Link: https://www.herber.de/bbs/user/56321.xls

Der Tom

  

Betrifft: AW: Subtraktion bis Wert erreicht (Zirkelbezug) von: Rudi Maintaire
Geschrieben am: 27.10.2008 12:48:52

Hallo,
und warum verteilst du den Topf nicht einfach anhand der Prozente in B????
=$H$2*B3

Gruß
Rudi


  

Betrifft: AW: Subtraktion bis Wert erreicht (Zirkelbezug) von: fcs
Geschrieben am: 27.10.2008 14:56:35

Hallo Tom,

folgende Formel teilt die Differenz prozentual zu den Einzahlungen in den Topf auf und zieht sie von der Auszahlung ab.

Formel in E3:
=RUNDEN(C3-A3/SUMME(A:A)*(SUMME(C:C)-$H$2);2)

macht in der Summe dann 1 Cent mehr.

Stattt RUNDEN kannst du auch mit ABRUNDEN arbeiten. Dann werden 22 Cent weniger ausgeschüttet.

Die Formel in E3 dann nach unten kopieren.

Gruß
Franz


  

Betrifft: AW: Subtraktion bis Wert erreicht (Zirkelbezug) von: Tom
Geschrieben am: 28.10.2008 14:08:03

Sorry....ging nicht schneller.

vielen Dank....ich muss mal testen, welche Variante ausreicht. Beide scheinen aber zu funktionieren.

Der Tom